summaryrefslogtreecommitdiff
path: root/dev-lang/hy/hy-0.11.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-lang/hy/hy-0.11.1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lang/hy/hy-0.11.1.ebuild')
-rw-r--r--dev-lang/hy/hy-0.11.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-lang/hy/hy-0.11.1.ebuild b/dev-lang/hy/hy-0.11.1.ebuild
deleted file mode 100644
index 409b60389bf9..000000000000
--- a/dev-lang/hy/hy-0.11.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-RESTRICT="test" # needs some pointy sticks. Seriously.
-PYTHON_COMPAT=(python{2_7,3_4,3_5})
-
-inherit distutils-r1 eutils
-DESCRIPTION="A LISP dialect running in python"
-HOMEPAGE="http://hylang.org/"
-SRC_URI="https://github.com/hylang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="test doc examples"
-
-RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]
- >=dev-python/rply-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/astor-0.5[${PYTHON_USEDEP}]
- dev-python/clint[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/tox[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- )"
-src_prepare() {
- use examples && EXAMPLES=( eg/. )
- use doc && HTML_DOCS=( docs/_build/html/. )
-}
-
-python_compile_all() {
- use doc && emake docs
-}
-
-python_test() {
- nosetests || die "Tests failed under ${EPYTHON}"
-}