summaryrefslogtreecommitdiff
path: root/dev-lang/haxe/haxe-4.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-23 01:00:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-23 01:00:42 +0000
commit6c169675dd21d25ad82ab0560f3d5b1e714219b6 (patch)
treeed786201c471d4535a5eca3a754866a856812bcb /dev-lang/haxe/haxe-4.3.1.ebuild
parent7fe6984499f95d52b3c32af6ab771aa8f08c2dd4 (diff)
gentoo auto-resync : 23:03:2024 - 01:00:42
Diffstat (limited to 'dev-lang/haxe/haxe-4.3.1.ebuild')
-rw-r--r--dev-lang/haxe/haxe-4.3.1.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-lang/haxe/haxe-4.3.1.ebuild b/dev-lang/haxe/haxe-4.3.1.ebuild
deleted file mode 100644
index 898185d66029..000000000000
--- a/dev-lang/haxe/haxe-4.3.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Multi-target universal programming language"
-HOMEPAGE="https://haxe.org/
- https://github.com/HaxeFoundation/haxe/"
-
-if [[ ${PV} == *9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/HaxeFoundation/haxe.git"
-else
- # Haxe-debian already contains correct git modules
- SRC_URI="https://github.com/HaxeFoundation/haxe-debian/archive/upstream/${PV}.tar.gz
- -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}"/haxe-debian-upstream-${PV}
-fi
-
-LICENSE="GPL-2+ MIT"
-SLOT="0/${PV}"
-IUSE="+ocamlopt"
-RESTRICT="strip"
-
-RDEPEND="
- >=dev-lang/ocaml-4:=[ocamlopt?]
- >=dev-ml/luv-0.5.12:=
- dev-ml/extlib:=
- dev-ml/ocaml-sha:=
- dev-ml/ptmap:=
- dev-ml/sedlex:=
- dev-ml/xml-light:=
-
- dev-lang/neko:=
- dev-libs/boehm-gc:=
- dev-libs/libpcre:=
- net-libs/mbedtls:=
- sys-libs/zlib:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-ml/camlp5
- dev-ml/dune
- dev-ml/findlib
-"
-
-QA_FLAGS_IGNORED="usr/bin/haxelib"
-QA_PRESTRIPPED="usr/bin/haxelib"
-
-src_configure() {
- export OCAMLOPT=$(usex ocamlopt ocamlopt.opt ocamlopt)
-}
-
-src_compile() {
- emake -j1 BRANCH="" COMMIT_DATE="" COMMIT_SHA="" \
- OCAMLOPT="${OCAMLOPT}" INSTALL_DIR=/usr
-}
-
-src_install() {
- emake DESTDIR="${D}" INSTALL_DIR=/usr install
- dodoc *.md
-}