summaryrefslogtreecommitdiff
path: root/dev-lang/haxe/haxe-4.2.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-10 21:52:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-10 21:52:51 +0100
commitfbba40085f5d1591a67b49f5aa48b4071b7560f1 (patch)
tree09e69d990e9c6d078ad475802b8728fa703bac9a /dev-lang/haxe/haxe-4.2.5-r2.ebuild
parent42e82780761e75f17a5cc96626558a297782f385 (diff)
gentoo auto-resync : 10:06:2023 - 21:52:51
Diffstat (limited to 'dev-lang/haxe/haxe-4.2.5-r2.ebuild')
-rw-r--r--dev-lang/haxe/haxe-4.2.5-r2.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-lang/haxe/haxe-4.2.5-r2.ebuild b/dev-lang/haxe/haxe-4.2.5-r2.ebuild
new file mode 100644
index 000000000000..2d349a639ef7
--- /dev/null
+++ b/dev-lang/haxe/haxe-4.2.5-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Multi-target universal programming language"
+HOMEPAGE="https://haxe.org/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/HaxeFoundation/haxe.git"
+else
+ # Haxe-debian already contains correct git modules
+ SRC_URI="https://github.com/HaxeFoundation/haxe-debian/archive/upstream/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}"/haxe-debian-upstream-${PV}
+fi
+
+LICENSE="GPL-2+ MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+RESTRICT="strip"
+
+# NOTICE: Does not compile with >=dev-ml/luv-0.5.12, but it's fixed on master.
+RDEPEND="
+ >=dev-lang/ocaml-4:=[ocamlopt?]
+ <dev-ml/luv-0.5.12:=
+ dev-ml/extlib:=
+ dev-ml/ocaml-sha:=
+ dev-ml/ptmap:=
+ dev-ml/sedlex:=
+ dev-ml/xml-light:=
+
+ dev-lang/neko:=
+ dev-libs/boehm-gc:=
+ dev-libs/libpcre:=
+ net-libs/mbedtls:=
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-ml/camlp5
+ dev-ml/dune
+ dev-ml/findlib
+"
+
+QA_FLAGS_IGNORED="usr/bin/haxelib"
+QA_PRESTRIPPED="usr/bin/haxelib"
+
+src_configure() {
+ if use ocamlopt ; then
+ export OCAMLOPT=ocamlopt.opt
+ else
+ export OCAMLOPT=ocamlopt
+ fi
+}
+
+src_compile() {
+ emake -j1 BRANCH="" COMMIT_DATE="" COMMIT_SHA="" \
+ OCAMLOPT="${OCAMLOPT}" INSTALL_DIR=/usr
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_DIR=/usr install
+ dodoc *.md
+}