summaryrefslogtreecommitdiff
path: root/dev-lang/haxe/haxe-4.2.4-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-23 20:53:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-23 20:53:51 +0100
commit3018b5a4bd4777c51e2793818305d7af2409a7fd (patch)
tree614c2151adcf4d5a47d494f83ec3f57d35f8e0a7 /dev-lang/haxe/haxe-4.2.4-r5.ebuild
parent2508f64d6edae6ffd910973df8285893a791b64a (diff)
gentoo auto-resync : 23:07:2023 - 20:53:51
Diffstat (limited to 'dev-lang/haxe/haxe-4.2.4-r5.ebuild')
-rw-r--r--dev-lang/haxe/haxe-4.2.4-r5.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-lang/haxe/haxe-4.2.4-r5.ebuild b/dev-lang/haxe/haxe-4.2.4-r5.ebuild
deleted file mode 100644
index b23db8502227..000000000000
--- a/dev-lang/haxe/haxe-4.2.4-r5.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Multi-target universal programming language"
-HOMEPAGE="https://haxe.org/"
-
-if [[ "${PV}" == *9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/HaxeFoundation/haxe.git"
-else
- # Haxe-debian already contains correct git modules
- SRC_URI="https://github.com/HaxeFoundation/haxe-debian/archive/upstream/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/haxe-debian-upstream-${PV}"
-fi
-
-LICENSE="GPL-2+ MIT"
-SLOT="0/${PV}"
-IUSE="+ocamlopt"
-
-# NOTICE: Does not compile with >=dev-ml/luv-0.5.12, but it's fixed on master.
-RDEPEND="
- >=dev-lang/ocaml-4:=[ocamlopt?]
- <dev-ml/luv-0.5.12:=
- dev-ml/extlib:=
- dev-ml/ocaml-sha:=
- dev-ml/ptmap:=
- dev-ml/sedlex:=
- dev-ml/xml-light:=
-
- dev-lang/neko:=
- dev-libs/boehm-gc:=
- dev-libs/libpcre:=
- net-libs/mbedtls:=
- sys-libs/zlib:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-ml/camlp5
- dev-ml/dune
- dev-ml/findlib
-"
-
-RESTRICT="strip"
-QA_FLAGS_IGNORED="usr/bin/haxelib"
-QA_PRESTRIPPED="usr/bin/haxelib"
-
-src_configure() {
- if use ocamlopt ; then
- export OCAMLOPT=ocamlopt.opt
- else
- export OCAMLOPT=ocamlopt
- fi
-}
-
-src_compile() {
- emake -j1 BRANCH="" COMMIT_DATE="" COMMIT_SHA="" \
- OCAMLOPT="${OCAMLOPT}" INSTALL_DIR=/usr
-}
-
-src_install() {
- emake DESTDIR="${D}" INSTALL_DIR=/usr install
- dodoc *.md
-}