summaryrefslogtreecommitdiff
path: root/dev-lang/go
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-21 23:40:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-21 23:40:13 +0000
commit51012ef0261a9da2e4487144906632d06607d3b9 (patch)
tree4bdd7443f88209d056985f2e4748277714e35829 /dev-lang/go
parentf2d1966a40070fb5ba3279db49b8435c7c143802 (diff)
gentoo auto-resync : 21:02:2024 - 23:40:13
Diffstat (limited to 'dev-lang/go')
-rw-r--r--dev-lang/go/Manifest4
-rw-r--r--dev-lang/go/go-9999.ebuild56
-rw-r--r--dev-lang/go/metadata.xml3
3 files changed, 38 insertions, 25 deletions
diff --git a/dev-lang/go/Manifest b/dev-lang/go/Manifest
index 7b6a2a1858bc..0eefc79942b6 100644
--- a/dev-lang/go/Manifest
+++ b/dev-lang/go/Manifest
@@ -24,5 +24,5 @@ EBUILD go-1.21.5.ebuild 5204 BLAKE2B 2fe9369fbc565c10082d5d508c863739e24e85dd491
EBUILD go-1.21.6.ebuild 5206 BLAKE2B d1618ba01d1c74873875216e306891cc6a0610a0fee57f433d681ff73f1f40d47d2318bda92afe8a0af1747cc0e4810919fc517afb284af8c446f16db2d31bb6 SHA512 74592fb84fb461020a617396f89f0393caf1a18943dce8c1b039dfb36c1d2a966b23c02d1a06a76793fb5b684e13ca503f8a59eb9bc6334c312167da67dc66c0
EBUILD go-1.21.7.ebuild 5209 BLAKE2B 5656d72770d2f5d6092328eeb3883f303407e591845530c2041df1382ffec3cde87c150ac591f4a4bebfa2dada0b504151c36e454d66269d31fe975eab786917 SHA512 d0b37538789f820c8314dbfbe9e8b5a18de1c3a8009d3e2633d6b4f0bdf1bd100374232f8323e7e55c67300e98f70468b3e26ea57153448d7bb24d629e9387e6
EBUILD go-1.22.0.ebuild 5274 BLAKE2B a5a2b88b048cb4a42f8d477ba507febfd99713bc9054847fa5a9beb5c0f8140c6ebc42b3bb87703f798a8dc8ee0067c7568b5d98e64a18ff617fafe98fe82faf SHA512 de58d78054b0281de2dd3bff87e9fcc8e6aa094c749ffcec398b7766dc4e2e7369179082e1193bb3dd9b913b75970ecc0144c0ba62a51225331ea55b4b15ce54
-EBUILD go-9999.ebuild 6330 BLAKE2B 7829044480a9f919c745cbc045345f63d084d402e0d8b0c2ae9908d917b190bbacae996e63e791b1dd2cc5f6ad6412ca75bede4ccd7201f53b00a252f323ffad SHA512 47d13be25722e7a64ef4303fe750117cf51e724f5293bb6d7f97a23e1b3d514a5334180546fb05217729f1b200e9f09d6c5570b214fb44d9f952f3f176570eaf
-MISC metadata.xml 589 BLAKE2B 341e4c0e91d73ca668c1795035e1223eed60f85c724afd989ef1f8fb69649f7f6eaaf8a5228f6c8f587ffcc40a438c47d332fbe6866839f5a0829872a983f642 SHA512 fe58ddddfbd4d0d060516cb035592a80c0f48e125bb59c95d3c6fac0c182271e2a9ec9bd055b9cc8e6cb8c449e6c483bff4a23c362f532c24255febfdefc273a
+EBUILD go-9999.ebuild 6645 BLAKE2B c8c30030e575ebc4f9215445dbe913809279084cde6df11c73b70117429a22f7e26f6bc5ca28e2522ca767b078b4269746f1a5beddc35f6ba0b4d79cde2393bb SHA512 bffee8ccf2e472fcea0171dc67cbb16d6310215f39d8cb9620f712c08b9542e7e45896aa077b1af259bf7e3bae9f6280983a25f692aff4f453ad177c0ed08ba9
+MISC metadata.xml 681 BLAKE2B 79c8b806f977b1f57a3f5fdf98a205405ce76c8700cc48e3e8458cf9e8bb6de872ebb5725b3212fc1042b5bd7950c8bed217abdbed955057a51a61225da838f8 SHA512 637e2a60649006a1570c532a90203833c6dd58bd0bf8e95c1962414c9250b87ce088ba2c6e511da43ccc800066d1752a8d0971585bf2be0d0bd47fd3fa8deb74
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index 401b23dc4e83..6b21274bfbf5 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -16,30 +16,32 @@ inherit toolchain-funcs
GO_BV=1.20.14
BOOTSTRAP_DIST="https://dev.gentoo.org/~williamh/dist"
SRC_URI="
- amd64? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-amd64-bootstrap.tbz )
- arm? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-arm-bootstrap.tbz )
- arm64? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-arm64-bootstrap.tbz )
- loong? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-loong64-bootstrap.tbz )
- mips? (
- abi_mips_o32? (
- big-endian? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-mips-bootstrap.tbz )
- !big-endian? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-mipsle-bootstrap.tbz )
- )
- abi_mips_n64? (
- big-endian? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-mips64-bootstrap.tbz )
- !big-endian? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-mips64le-bootstrap.tbz )
+ !system-bootstrap? (
+ amd64? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-amd64-bootstrap.tbz )
+ arm? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-arm-bootstrap.tbz )
+ arm64? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-arm64-bootstrap.tbz )
+ loong? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-loong64-bootstrap.tbz )
+ mips? (
+ abi_mips_o32? (
+ big-endian? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-mips-bootstrap.tbz )
+ !big-endian? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-mipsle-bootstrap.tbz )
+ )
+ abi_mips_n64? (
+ big-endian? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-mips64-bootstrap.tbz )
+ !big-endian? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-mips64le-bootstrap.tbz )
+ )
)
+ ppc64? (
+ big-endian? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-ppc64-bootstrap.tbz )
+ !big-endian? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-ppc64le-bootstrap.tbz )
)
- ppc64? (
- big-endian? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-ppc64-bootstrap.tbz )
- !big-endian? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-ppc64le-bootstrap.tbz )
+ riscv? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-riscv64-bootstrap.tbz )
+ s390? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-s390x-bootstrap.tbz )
+ x86? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-386-bootstrap.tbz )
+ x64-macos? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-darwin-amd64-bootstrap.tbz )
+ arm64-macos? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-darwin-arm64-bootstrap.tbz )
+ x64-solaris? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-solaris-amd64-bootstrap.tbz )
)
- riscv? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-riscv64-bootstrap.tbz )
- s390? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-s390x-bootstrap.tbz )
- x86? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-linux-386-bootstrap.tbz )
- x64-macos? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-darwin-amd64-bootstrap.tbz )
- arm64-macos? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-darwin-arm64-bootstrap.tbz )
- x64-solaris? ( ${BOOTSTRAP_DIST}/go-${GO_BV}-solaris-amd64-bootstrap.tbz )
"
case ${PV} in
@@ -63,7 +65,7 @@ HOMEPAGE="https://go.dev"
LICENSE="BSD"
SLOT="0/${PV}"
-IUSE="abi_mips_o32 abi_mips_n64 cpu_flags_x86_sse2 big-endian"
+IUSE="abi_mips_o32 abi_mips_n64 big-endian system-bootstrap"
RDEPEND="
arm? ( sys-devel/binutils[gold] )
@@ -171,7 +173,15 @@ src_compile() {
use x86 && export GO386=$(usex cpu_flags_x86_sse2 '' 'softfloat')
export GOROOT="${PWD}"
- export GOROOT_BOOTSTRAP="${WORKDIR}/go-${GOOS}-${GOARCH}-bootstrap"
+ if use system-bootstrap; then
+ if has_version <dev-lang/go-${GO_BV}; then
+ eerror "You need at least dev-lang/go-${GO_BV} installed to bootstrap this version of go"
+ die "version of go is too old"
+ fi
+ export GOROOT_BOOTSTRAP="${EPREFIX}/usr/lib/go"
+ else
+ export GOROOT_BOOTSTRAP="${WORKDIR}/go-${GOOS}-${GOARCH}-bootstrap"
+ fi
export GOROOT_FINAL="${EPREFIX}"/usr/lib/go
export GOBIN="${GOROOT}/bin"
diff --git a/dev-lang/go/metadata.xml b/dev-lang/go/metadata.xml
index 5e00214a73f6..51455ddf8e9f 100644
--- a/dev-lang/go/metadata.xml
+++ b/dev-lang/go/metadata.xml
@@ -14,4 +14,7 @@
<remote-id type="cpe">cpe:/a:golang:go</remote-id>
<remote-id type="github">golang/go</remote-id>
</upstream>
+ <use>
+ <flag name="system-bootstrap">Bootstrap using installed go compiler</flag>
+ </use>
</pkgmetadata>