summaryrefslogtreecommitdiff
path: root/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-02 17:41:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-02 17:41:59 +0000
commit7c58ecff5764af03b4c65f4115d7b9474e3a5717 (patch)
tree569bdc11cba2d203e04530a1a0dcdc4b52a46de1 /dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
parent708c31c860cb6292743b80e3371ccccffb0c9bbd (diff)
gentoo auto-resync : 02:03:2024 - 17:41:59
Diffstat (limited to 'dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild')
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
index c90d5ac44036..002368b2c0c0 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -50,6 +50,13 @@ BDEPEND=sys-devel/binutils
S="${WORKDIR}"/${MYP}
+pkg_pretend() {
+ toolchain_pkg_pretend
+ if tc-is-clang; then
+ die "${P} does not build with clang. It is bootstrapped."
+ fi
+}
+
src_prepare() {
if use amd64; then
BTSTRP=${BTSTRP_AMD64}