summaryrefslogtreecommitdiff
path: root/dev-lang/gnat-gpl/gnat-gpl-2018-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-lang/gnat-gpl/gnat-gpl-2018-r3.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-lang/gnat-gpl/gnat-gpl-2018-r3.ebuild')
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2018-r3.ebuild30
1 files changed, 13 insertions, 17 deletions
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2018-r3.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2018-r3.ebuild
index bb4782b8d4be..87b416731cdb 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2018-r3.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2018-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -50,9 +50,18 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/${MYP}
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
-pkg_setup() {
- toolchain_pkg_setup
+src_unpack() {
+ if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
+ eerror "You need a gcc compiler that provides the Ada Compiler:"
+ eerror "1) use gcc-config to select the right compiler or"
+ eerror "2) set the bootstrap use flag"
+ die "ada compiler not available"
+ fi
+
+ toolchain_src_unpack
+}
+src_prepare() {
if use amd64; then
BTSTRP=${BTSTRP_AMD64}
else
@@ -72,23 +81,10 @@ pkg_setup() {
if [[ ${gnatpath} != "." ]] ; then
GNATMAKE="${gnatpath}/${GNATMAKE}"
fi
-}
-
-src_unpack() {
- if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
- eerror "You need a gcc compiler that provides the Ada Compiler:"
- eerror "1) use gcc-config to select the right compiler or"
- eerror "2) set the bootstrap use flag"
- die "ada compiler not available"
- fi
-
- toolchain_src_unpack
if use bootstrap; then
- rm ${BTSTRP}/libexec/gcc/*/4.7.4/ld || die
+ rm "${WORKDIR}"/${BTSTRP}/libexec/gcc/*/4.7.4/ld || die
fi
-}
-src_prepare() {
CC=${GCC}
CXX="${gnatbase/gcc/g++}"
GNATBIND="${gnatbase/gcc/gnatbind}"