summaryrefslogtreecommitdiff
path: root/dev-lang/ghc/ghc-8.10.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-lang/ghc/ghc-8.10.4.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-lang/ghc/ghc-8.10.4.ebuild')
-rw-r--r--dev-lang/ghc/ghc-8.10.4.ebuild20
1 files changed, 18 insertions, 2 deletions
diff --git a/dev-lang/ghc/ghc-8.10.4.ebuild b/dev-lang/ghc/ghc-8.10.4.ebuild
index 7257681ccbe7..3e4cfb0d0db8 100644
--- a/dev-lang/ghc/ghc-8.10.4.ebuild
+++ b/dev-lang/ghc/ghc-8.10.4.ebuild
@@ -13,6 +13,8 @@ if [[ ${CTARGET} = ${CHOST} ]] ; then
fi
fi
+PYTHON_COMPAT=( python3_{7..9} )
+inherit python-any-r1
inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
inherit multilib multiprocessing pax-utils toolchain-funcs prefix
inherit check-reqs
@@ -105,13 +107,23 @@ PREBUILT_BINARY_RDEPENDS="${PREBUILT_BINARY_DEPENDS}
RDEPEND+="binary? ( ${PREBUILT_BINARY_RDEPENDS} )"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
doc? ( app-text/docbook-xml-dtd:4.2
app-text/docbook-xml-dtd:4.5
app-text/docbook-xsl-stylesheets
dev-python/sphinx
>=dev-libs/libxslt-1.1.2 )
- !ghcbootstrap? ( ${PREBUILT_BINARY_DEPENDS} )"
+ !ghcbootstrap? ( ${PREBUILT_BINARY_DEPENDS} )
+ test? ( ${PYTHON_DEPS} )
+"
+
+needs_python() {
+ # test driver is written in python
+ use test && return 0
+ return 1
+}
# we build binaries without profiling support
REQUIRED_USE="
@@ -379,6 +391,10 @@ pkg_setup() {
die "No binary available for '${ARCH}' arch yet, USE=ghcbootstrap"
fi
fi
+
+ if needs_python; then
+ python-any-r1_pkg_setup
+ fi
}
src_unpack() {