summaryrefslogtreecommitdiff
path: root/dev-lang/gforth/gforth-0.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
commitea31ad0ed5501d0bf92267c35beaf06ac016bad2 (patch)
tree2fdc433d571e3ead010876d43ce2646b7d783680 /dev-lang/gforth/gforth-0.7.3.ebuild
parent88ebe56470c37b02a044e1091cad6b2df0f3be8f (diff)
gentoo resync : 13.05.2018
Diffstat (limited to 'dev-lang/gforth/gforth-0.7.3.ebuild')
-rw-r--r--dev-lang/gforth/gforth-0.7.3.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-lang/gforth/gforth-0.7.3.ebuild b/dev-lang/gforth/gforth-0.7.3.ebuild
deleted file mode 100644
index bcb4ec21a59f..000000000000
--- a/dev-lang/gforth/gforth-0.7.3.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit elisp-common eutils
-
-DESCRIPTION="GNU Forth is a fast and portable implementation of the ANSI Forth language"
-HOMEPAGE="https://www.gnu.org/software/gforth"
-SRC_URI="mirror://gnu/gforth/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
-IUSE="emacs"
-
-DEPEND="dev-libs/ffcall
- emacs? ( virtual/emacs )"
-RDEPEND="${DEPEND}"
-
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-0.7.0-make-elc.patch"
- epatch_user
-}
-
-src_configure() {
- # May want to add a USE flag for --enable-force-cdiv, if necessary
- # At this point I do not know when that is appropriate, and I don't
- # want to add an ebuild-specific USE flag without understanding.
- econf \
- --without-check \
- $(use emacs || echo "--without-lispdir")
-}
-
-src_compile() {
- # Parallel make breaks here
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc AUTHORS BUGS ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
-
- if use emacs; then
- elisp-install ${PN} gforth.el gforth.elc
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}