summaryrefslogtreecommitdiff
path: root/dev-lang/fennel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-lang/fennel
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-lang/fennel')
-rw-r--r--dev-lang/fennel/Manifest4
-rw-r--r--dev-lang/fennel/fennel-1.0.0.ebuild36
-rw-r--r--dev-lang/fennel/metadata.xml18
3 files changed, 45 insertions, 13 deletions
diff --git a/dev-lang/fennel/Manifest b/dev-lang/fennel/Manifest
index 4aa072db68cb..3aa1e3790f1b 100644
--- a/dev-lang/fennel/Manifest
+++ b/dev-lang/fennel/Manifest
@@ -1,3 +1,5 @@
DIST fennel-0.9.1.tar.gz 203441 BLAKE2B 74f461b3e7a24cdae0c8dde590814cb9753a12ab62e797746cc8753d178007a09084037e443d8309fa11ff309a5c6bf6c2e369942ef357aa0402883cef278542 SHA512 87e7ffbef0b49499a93255f50e77f53b9be4faa6d4609d8d65e3a64470bbf07b49a55e7dd547fda4b0e5fe0f4f1e6ece18282cc89955a57ed0a50be8dc01261c
+DIST fennel-1.0.0.tar.gz 243719 BLAKE2B 07758493c8c96d2d5151a1cb38da9fec002eb2522926dc2cad0a125c3e608daf2035a3d21743a8634a5fd0cab372e78ee0179710388c56888cb9a2fef167ea58 SHA512 4ad1635807d244297fdc7bf7c06568ae708ae805dcaac2bb190fad412da21c9e3c3b86a6afa223e343488c725afea94682f213332fb22ba66eb5190e97f18415
EBUILD fennel-0.9.1.ebuild 698 BLAKE2B d3c81fa72bb2170bf88561787454a3c0d3989a03fe45108940131a29e5ee7a09cc0cdecb4d79bcfe1eaf37d203ff873dddbdea88a575e6de5b7ac01c265bcae0 SHA512 0815d701b3dc08d86bf39187e47e7c595c9ec9814fe467fbdc4c2b7453e489da1b631af058dd38fc853ef3a1835c59b33c750977baf4a9859bc539d211332fab
-MISC metadata.xml 1139 BLAKE2B e153636da247b351e1c8844b523e44620ba59674d6b118d65c860b9cd1ceffb69af426704ba3dddfa9722775dae8a8ac7ff521d1eae40e049e1ce82253ab0273 SHA512 ac1acd2a6bc0b2367f2101d28a7aa66143baea7d4ff74656933d3ac507de22f19bbf3d8474a74e804e7aeac40f058a106199c2d2055a5b76d66a3e2a41ebf4a1
+EBUILD fennel-1.0.0.ebuild 768 BLAKE2B 857588a2f43031d3a7121d3d8637e4b1e3fdf2daf15a4e3fbe01179e9377e321b68729c007bdeb4417d56844c7571c852795ce2af59e02340152e7b7406a161e SHA512 517a32ac814917f4e06cc84727539db24cc8b8860ddf13d557f13bad229d0270b50f4fe968e55d9409ad8cfdc31d8c5db9525093fc3004ac80c62a5889ded2b3
+MISC metadata.xml 971 BLAKE2B fb528fc59062b5f9d2ca50f27e7f989a8693fe89ca0979efde13ca67689cc3921d30747ca9a7c82a80f78962adfec490372365cf4ff38f7b1af742bb97ec3a9c SHA512 9ec6509279507fbd57bed8ec01cc9ab57aa6098ba543e288b6058e065ac9bcdc787840967bf06d810d5872af331862e8962366dcc79e1a4070e6628db78c41a3
diff --git a/dev-lang/fennel/fennel-1.0.0.ebuild b/dev-lang/fennel/fennel-1.0.0.ebuild
new file mode 100644
index 000000000000..f470a84c2717
--- /dev/null
+++ b/dev-lang/fennel/fennel-1.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Fails to build with with lua5-1
+LUA_COMPAT=( lua5-{3,4} luajit )
+
+inherit lua-single
+
+DESCRIPTION="Lisp-like language that compiles to Lua"
+HOMEPAGE="https://fennel-lang.org/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~technomancy/${PN}"
+else
+ SRC_URI="https://git.sr.ht/~technomancy/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ emake LUA_LIB_DIR="${ED}/$(lua_get_lmod_dir)" PREFIX="${ED}/usr" install
+
+ rm -r "${ED}"/usr/man || die
+ doman ${PN}.1
+
+ dodoc *.md
+}
diff --git a/dev-lang/fennel/metadata.xml b/dev-lang/fennel/metadata.xml
index 7be4ec2ae425..001e74a2f442 100644
--- a/dev-lang/fennel/metadata.xml
+++ b/dev-lang/fennel/metadata.xml
@@ -1,29 +1,23 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>xgqt@gentoo.org</email>
<name>Maciej Barć</name>
</maintainer>
- <longdescription lang="en">
+ <longdescription>
Fennel is a lisp that compiles to Lua. It aims to be easy to use,
expressive, and has almost zero overhead compared to handwritten Lua.
-
- - Full Lua compatibility - You can use any function or library from Lua.
- - Zero overhead - Compiled code should be just as or more efficient
+ Full Lua compatibility - You can use any function or library from Lua.
+ Zero overhead - Compiled code should be just as or more efficient
than hand-written Lua.
- - Compile-time macros - Ship compiled code with no runtime dependency
+ Compile-time macros - Ship compiled code with no runtime dependency
on Fennel.
- - Embeddable - Fennel is a one-file library as well as an executable.
+ Embeddable - Fennel is a one-file library as well as an executable.
Embed it in other programs to support runtime extensibility and
interactive development.
-
At https://fennel-lang.org there's a live in-browser REPL you can use
without installing anything.
</longdescription>
- <upstream>
- <bugs-to>https://github.com/bakpakin/Fennel/issues</bugs-to>
- <remote-id type="github">bakpakin/Fennel</remote-id>
- </upstream>
</pkgmetadata>