summaryrefslogtreecommitdiff
path: root/dev-lang/elpi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-15 06:20:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-15 06:20:30 +0000
commitbb007f0b04c719fd2b846d177c3c4739fdb7c318 (patch)
tree80f756c3d190f4dbf28e8016c211ab618a50ccb9 /dev-lang/elpi
parent1f048d9b860b8c7b69ac8dd085edc9ee3191b2d5 (diff)
gentoo auto-resync : 15:03:2023 - 06:20:30
Diffstat (limited to 'dev-lang/elpi')
-rw-r--r--dev-lang/elpi/Manifest3
-rw-r--r--dev-lang/elpi/elpi-1.16.9.ebuild47
-rw-r--r--dev-lang/elpi/metadata.xml27
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-lang/elpi/Manifest b/dev-lang/elpi/Manifest
new file mode 100644
index 000000000000..3eeedfb8cc26
--- /dev/null
+++ b/dev-lang/elpi/Manifest
@@ -0,0 +1,3 @@
+DIST elpi-1.16.9.tar.gz 2601448 BLAKE2B 37dd239cae112e6ec1c913dc9fdba60d829c0bbf61876f9c98b927d5d359ed5376ea1663da7e6c808bd62d61380973de7ae649d4a0dddef172f8d2599cc18c35 SHA512 89896c0f5d2e9a8ec6d7ef666a0d11c12b670e6951e277c2d29095b3fcbb5a977416cd1876c4c2d8c14b826782b095d3a453db03bebe3438f0eeacc08c7c87fc
+EBUILD elpi-1.16.9.ebuild 887 BLAKE2B 8025ea6763693e53cdc7fb40c5a769ce381d9f37bf8c5e087cc2d2fc19ba654a88d047f6b228aa7086ab1dd631f1121651fd1dca424860fedd7da66de4d0ce0a SHA512 ee52ec3bbb6b66bb0e928e7e9379acd083490ed231a97d7a909856e22369bda85946056495f7376c3fcc2b5d9f1c826e848777f71913b35f776d3bc0b54d1545
+MISC metadata.xml 1145 BLAKE2B 5dc8cfaed7392d45c7c30034952ea7796569ab084912ff15ff6be6e9977376845b539d3b129c1c5572d5dfba2a34caf6e458f4ff52b9bea37330287f2105549a SHA512 f7f7911e2cbd2a25cf02e4aa4710953bf31db35721e2100838f681ea064476c972e2a8b1426afe5b653fa64571791e0c956d63c4cd65d002390f0587611f4b74
diff --git a/dev-lang/elpi/elpi-1.16.9.ebuild b/dev-lang/elpi/elpi-1.16.9.ebuild
new file mode 100644
index 000000000000..184849b51e67
--- /dev/null
+++ b/dev-lang/elpi/elpi-1.16.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Embeddable Lambda Prolog Interpreter in OCaml"
+HOMEPAGE="https://github.com/LPCIC/elpi/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/LPCIC/${PN}.git"
+else
+ SRC_URI="https://github.com/LPCIC/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0/${PV}"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=
+ >=dev-ml/menhir-20211230:=
+ dev-ml/atd:=
+ dev-ml/ppx_deriving:=
+ dev-ml/ppxlib:=
+ dev-ml/re:=
+ dev-ml/stdlib-shims:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-ml/ANSITerminal
+ dev-ml/cmdliner
+ )
+"
+
+DOCS=( AUTHORS.md CHANGES.md ELPI.md INCOMPATIBILITIES.md README.md )
+
+src_install() {
+ dune_src_install
+ einstalldocs
+}
diff --git a/dev-lang/elpi/metadata.xml b/dev-lang/elpi/metadata.xml
new file mode 100644
index 000000000000..30a70f111a2f
--- /dev/null
+++ b/dev-lang/elpi/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ ELPI implements a variant of λProlog enriched with Constraint Handling
+ Rules, a programming language well suited to manipulate syntax trees with
+ binders. ELPI is designed to be embedded into larger applications written
+ in OCaml as an extension language. It comes with an API to drive the
+ interpreter and with an FFI for defining built-in predicates and data
+ types, as well as quotations and similar goodies that are handy to adapt
+ the language to the host application.
+ </longdescription>
+ <upstream>
+ <changelog>https://raw.githubusercontent.com/LPCIC/elpi/master/CHANGES.md</changelog>
+ <bugs-to>https://github.com/LPCIC/elpi/issues/</bugs-to>
+ <remote-id type="github">LPCIC/elpi</remote-id>
+ </upstream>
+</pkgmetadata>