summaryrefslogtreecommitdiff
path: root/dev-lang/elpi/elpi-1.16.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-15 06:20:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-15 06:20:30 +0000
commitbb007f0b04c719fd2b846d177c3c4739fdb7c318 (patch)
tree80f756c3d190f4dbf28e8016c211ab618a50ccb9 /dev-lang/elpi/elpi-1.16.9.ebuild
parent1f048d9b860b8c7b69ac8dd085edc9ee3191b2d5 (diff)
gentoo auto-resync : 15:03:2023 - 06:20:30
Diffstat (limited to 'dev-lang/elpi/elpi-1.16.9.ebuild')
-rw-r--r--dev-lang/elpi/elpi-1.16.9.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-lang/elpi/elpi-1.16.9.ebuild b/dev-lang/elpi/elpi-1.16.9.ebuild
new file mode 100644
index 000000000000..184849b51e67
--- /dev/null
+++ b/dev-lang/elpi/elpi-1.16.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Embeddable Lambda Prolog Interpreter in OCaml"
+HOMEPAGE="https://github.com/LPCIC/elpi/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/LPCIC/${PN}.git"
+else
+ SRC_URI="https://github.com/LPCIC/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0/${PV}"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=
+ >=dev-ml/menhir-20211230:=
+ dev-ml/atd:=
+ dev-ml/ppx_deriving:=
+ dev-ml/ppxlib:=
+ dev-ml/re:=
+ dev-ml/stdlib-shims:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-ml/ANSITerminal
+ dev-ml/cmdliner
+ )
+"
+
+DOCS=( AUTHORS.md CHANGES.md ELPI.md INCOMPATIBILITIES.md README.md )
+
+src_install() {
+ dune_src_install
+ einstalldocs
+}