summaryrefslogtreecommitdiff
path: root/dev-lang/eisl/eisl-2.65.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-22 19:06:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-22 19:06:54 +0000
commit664924d8659185e3b43f99ee8a0b88177efb93dc (patch)
treeaed90b6643b91860a6e68a4a6ef39b5747ed3b31 /dev-lang/eisl/eisl-2.65.ebuild
parent5d0c50eb490582cf1277e150ee5bb63a90b85aa6 (diff)
gentoo auto-resync : 22:11:2022 - 19:06:54
Diffstat (limited to 'dev-lang/eisl/eisl-2.65.ebuild')
-rw-r--r--dev-lang/eisl/eisl-2.65.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/eisl/eisl-2.65.ebuild b/dev-lang/eisl/eisl-2.65.ebuild
new file mode 100644
index 000000000000..878cafaf25b7
--- /dev/null
+++ b/dev-lang/eisl/eisl-2.65.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Interpreter and compiler compatible with the ISLisp standard"
+HOMEPAGE="https://github.com/sasagawa888/eisl/"
+SRC_URI="https://github.com/sasagawa888/eisl/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Tests run cppcheck (and fail)
+
+DOCS=( README{,-ja}.md documents )
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.63-Makefile.patch )
+
+src_compile() {
+ emake CC="$(tc-getCC)" clean edlis eisl
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe edlis eisl
+
+ # Compilation of ISLisp files on installation fails.
+ # Do not compile them and mimic "make install".
+ insinto /usr/share/${PN}
+ doins -r library
+ doins fast.h ffi.h
+
+ einstalldocs
+}