summaryrefslogtreecommitdiff
path: root/dev-lang/eisl/eisl-2.63.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-16 11:14:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-16 11:14:46 +0100
commitacb0389058b8ef612d851b1ab54fa37376c4b7f7 (patch)
treeb1e68406cfd137e951d13c4307e3c2fac7ae0087 /dev-lang/eisl/eisl-2.63.ebuild
parent121b314457e147271cd95353cf8886d35b329845 (diff)
gentoo auto-resync : 16:09:2022 - 11:14:45
Diffstat (limited to 'dev-lang/eisl/eisl-2.63.ebuild')
-rw-r--r--dev-lang/eisl/eisl-2.63.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/eisl/eisl-2.63.ebuild b/dev-lang/eisl/eisl-2.63.ebuild
new file mode 100644
index 000000000000..3b3256166271
--- /dev/null
+++ b/dev-lang/eisl/eisl-2.63.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Interpreter and compiler compatible with the ISLisp standard"
+HOMEPAGE="https://github.com/sasagawa888/eisl/"
+SRC_URI="https://github.com/sasagawa888/eisl/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Tests run cppcheck (and fail)
+
+DOCS=( README{,-ja}.md documents )
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-Makefile.patch )
+
+src_compile() {
+ emake CC="$(tc-getCC)" clean edlis eisl
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe edlis eisl
+
+ # Compilation of ISLisp files on installation fails.
+ # Do not compile them and mimic "make install".
+ insinto /usr/share/${PN}
+ doins -r library
+ doins fast.h ffi.h
+
+ einstalldocs
+}