summaryrefslogtreecommitdiff
path: root/dev-lang/eisl/eisl-2.60.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-06 14:10:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-06 14:10:02 +0100
commit7e17b5aabc330abb894f2b90bef0e3fcbcd180d2 (patch)
tree0b0cd08ce6e24faf7c868b07127ee0b6b32153c7 /dev-lang/eisl/eisl-2.60.ebuild
parentda3552023d9aae2ee5183df71a80a8169414974e (diff)
gentoo auto-resync : 06:08:2022 - 14:10:01
Diffstat (limited to 'dev-lang/eisl/eisl-2.60.ebuild')
-rw-r--r--dev-lang/eisl/eisl-2.60.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lang/eisl/eisl-2.60.ebuild b/dev-lang/eisl/eisl-2.60.ebuild
new file mode 100644
index 000000000000..d3860f96fe30
--- /dev/null
+++ b/dev-lang/eisl/eisl-2.60.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Interpreter and compiler compatible with the ISLisp standard"
+HOMEPAGE="https://github.com/sasagawa888/eisl/"
+SRC_URI="https://github.com/sasagawa888/eisl/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Tests run cppcheck (and fail)
+
+DOCS=( README-ja.md README.md documents )
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.50-Makefile.patch )
+
+src_compile() {
+ emake CC="$(tc-getCC)" clean all
+}
+
+src_install() {
+ dobin edlis eisl
+
+ insinto /usr/lib/${PN}
+ doins library/*
+
+ einstalldocs
+}