summaryrefslogtreecommitdiff
path: root/dev-lang/crystal/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-25 18:13:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-25 18:13:05 +0100
commitc7b5a281b2f19df584053abc11abb47ccad9c381 (patch)
tree982904bec5cf328955b044b4aa3a0788ff5fbc01 /dev-lang/crystal/files
parent403ab7c9007c3a5ff376f2a5d8963c5db58813fb (diff)
gentoo auto-resync : 25:04:2023 - 18:13:05
Diffstat (limited to 'dev-lang/crystal/files')
-rw-r--r--dev-lang/crystal/files/crystal-0.26.1-gentoo-tests-sandbox.patch22
-rw-r--r--dev-lang/crystal/files/crystal-0.27.0-extra-spec-flags.patch11
2 files changed, 0 insertions, 33 deletions
diff --git a/dev-lang/crystal/files/crystal-0.26.1-gentoo-tests-sandbox.patch b/dev-lang/crystal/files/crystal-0.26.1-gentoo-tests-sandbox.patch
deleted file mode 100644
index cab165c39059..000000000000
--- a/dev-lang/crystal/files/crystal-0.26.1-gentoo-tests-sandbox.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/spec/std/file_spec.cr
-+++ b/spec/std/file_spec.cr
-@@ -1164,3 +1164,4 @@ describe "File" do
- # TODO: there is no file which is reliably unwritable on windows
-- pending_win32 "raises if file cannot be accessed" do
-+ # On linux(or sandbox?) it's "Permission denied", not "Operation not permitted"
-+ pending "raises if file cannot be accessed" do
- expect_raises Errno, "Operation not permitted" do
---- a/spec/std/process_spec.cr
-+++ b/spec/std/process_spec.cr
-@@ -135,3 +135,4 @@ describe Process do
- describe "environ" do
-- it "clears the environment" do
-+ #gentoo's sandbox keeps sandbox environment
-+ pending "clears the environment" do
- value = Process.run("env", clear_env: true) do |proc|
-@@ -142,3 +143,4 @@ describe Process do
-
-- it "sets an environment variable" do
-+ #gentoo's sandbox keeps sandbox environment
-+ pending "sets an environment variable" do
- env = {"FOO" => "bar"}
diff --git a/dev-lang/crystal/files/crystal-0.27.0-extra-spec-flags.patch b/dev-lang/crystal/files/crystal-0.27.0-extra-spec-flags.patch
deleted file mode 100644
index bd86c13a78a6..000000000000
--- a/dev-lang/crystal/files/crystal-0.27.0-extra-spec-flags.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-Allow injecting additional arguments to test suite.
-Useful to be able to run small subset of individual
-test suite:
-
- make spec EXTRA_SPEC_FLAGS='-e parse_set_cookie'
-
---- a/Makefile
-+++ b/Makefile
-@@ -31 +31 @@ override FLAGS += $(if $(release),--release )$(if $(stats),--stats )$(if $(progr
--SPEC_FLAGS := $(if $(verbose),-v )$(if $(junit_output),--junit_output $(junit_output) )
-+SPEC_FLAGS := $(if $(verbose),-v )$(if $(junit_output),--junit_output $(junit_output) )$(EXTRA_SPEC_FLAGS)