summaryrefslogtreecommitdiff
path: root/dev-lang/crystal/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-lang/crystal/files
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-lang/crystal/files')
-rw-r--r--dev-lang/crystal/files/crystal-0.26.1-gentoo-tests-network-sandbox-3.patch26
-rw-r--r--dev-lang/crystal/files/crystal-0.27.0-tcp-server-test.patch12
-rw-r--r--dev-lang/crystal/files/crystal-0.27.1-verbose.patch7
3 files changed, 0 insertions, 45 deletions
diff --git a/dev-lang/crystal/files/crystal-0.26.1-gentoo-tests-network-sandbox-3.patch b/dev-lang/crystal/files/crystal-0.26.1-gentoo-tests-network-sandbox-3.patch
deleted file mode 100644
index eb1b84ce618c..000000000000
--- a/dev-lang/crystal/files/crystal-0.26.1-gentoo-tests-network-sandbox-3.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/spec/std/http/server/server_spec.cr b/spec/std/http/server/server_spec.cr
-index 9de0c3f..59882db 100644
---- a/spec/std/http/server/server_spec.cr
-+++ b/spec/std/http/server/server_spec.cr
-@@ -400,7 +400,9 @@ module HTTP
- end
-
- describe "#bind_tls" do
-- it "binds SSL server context" do
-+ # gentoo's FEATURES=network-sandbox blocks external network:
-+ # connect: Connection timed out (Errno)
-+ pending "binds SSL server context" do
- server = Server.new do |context|
- context.response.puts "Test Server (#{context.request.headers["Host"]?})"
- context.response.close
-@@ -512,7 +514,9 @@ module HTTP
- end
- {% end %}
-
-- it "handles exception during SSL handshake (#6577)" do
-+ # gentoo's FEATURES=network-sandbox blocks external network:
-+ # connect: Connection timed out (Errno)
-+ pending "handles exception during SSL handshake (#6577)" do
- server = SilentErrorHTTPServer.new do |context|
- context.response.print "ok"
- context.response.close
diff --git a/dev-lang/crystal/files/crystal-0.27.0-tcp-server-test.patch b/dev-lang/crystal/files/crystal-0.27.0-tcp-server-test.patch
deleted file mode 100644
index 8f61c8aeef47..000000000000
--- a/dev-lang/crystal/files/crystal-0.27.0-tcp-server-test.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/spec/std/http/server/server_spec.cr
-+++ b/spec/std/http/server/server_spec.cr
-@@ -524,7 +524,8 @@ module HTTP
- end
-
- describe "#close" do
-- it "closes gracefully" do
-+ # fails under gentoo's sandbox
-+ pending "closes gracefully" do
- server = Server.new do |context|
- context.response.flush
- context.response.puts "foo"
diff --git a/dev-lang/crystal/files/crystal-0.27.1-verbose.patch b/dev-lang/crystal/files/crystal-0.27.1-verbose.patch
deleted file mode 100644
index 33c3c5d61c41..000000000000
--- a/dev-lang/crystal/files/crystal-0.27.1-verbose.patch
+++ /dev/null
@@ -1,7 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -29,3 +29,3 @@ SOURCES := $(shell find src -name '*.cr')
- SPEC_SOURCES := $(shell find spec -name '*.cr')
--override FLAGS += -D preview_overflow -D compiler_rt $(if $(release),--release )$(if $(stats),--stats )$(if $(progress),--progress )$(if $(threads),--threads $(threads) )$(if $(debug),-d )$(if $(static),--static )$(if $(LDFLAGS),--link-flags="$(LDFLAGS)" )
-+override FLAGS += -D preview_overflow -D compiler_rt $(if $(release),--release )$(if $(stats),--stats )$(if $(progress),--progress )$(if $(threads),--threads $(threads) )$(if $(debug),-d )$(if $(static),--static )$(if $(LDFLAGS),--link-flags="$(LDFLAGS)" )$(if $(verbose),--verbose )
- SPEC_FLAGS := $(if $(verbose),-v )$(if $(junit_output),--junit_output $(junit_output) )