summaryrefslogtreecommitdiff
path: root/dev-lang/coffee-script/coffee-script-1.12.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-lang/coffee-script/coffee-script-1.12.5.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lang/coffee-script/coffee-script-1.12.5.ebuild')
-rw-r--r--dev-lang/coffee-script/coffee-script-1.12.5.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-lang/coffee-script/coffee-script-1.12.5.ebuild b/dev-lang/coffee-script/coffee-script-1.12.5.ebuild
deleted file mode 100644
index 6029b25ed394..000000000000
--- a/dev-lang/coffee-script/coffee-script-1.12.5.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN="coffeescript"
-
-DESCRIPTION="A little language that compiles into javascript"
-HOMEPAGE="https://coffeescript.org/"
-SRC_URI="https://github.com/jashkenas/${MY_PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# This package has a test suite (that works), but it requires a number
-# of NodeJS/NPM packages that aren't in the tree.
-IUSE="doc examples"
-
-RDEPEND="net-libs/nodejs"
-
-src_install(){
- local npm_module_dir="/usr/$(get_libdir)/node/${PN}"
- insinto "${npm_module_dir}"
- doins *.js package.json
- doins -r lib
- dodoc CONTRIBUTING.md README.md
-
- use doc && dodoc -r documentation
- use examples && dodoc -r examples
-
- # The coffee and cake "binaries" use a relative path to find the lib
- # directory, so we have to symlink them rather than use dobin().
- exeinto "${npm_module_dir}/bin"
- doexe bin/cake
- doexe bin/coffee
- dosym "${npm_module_dir}/bin/cake" "/usr/bin/cake"
- dosym "${npm_module_dir}/bin/coffee" "/usr/bin/coffee"
-}