summaryrefslogtreecommitdiff
path: root/dev-lang/bff/bff-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-lang/bff/bff-1.0.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-lang/bff/bff-1.0.5.ebuild')
-rw-r--r--dev-lang/bff/bff-1.0.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lang/bff/bff-1.0.5.ebuild b/dev-lang/bff/bff-1.0.5.ebuild
new file mode 100644
index 000000000000..b0504e8a5fee
--- /dev/null
+++ b/dev-lang/bff/bff-1.0.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A brainfuck interpreter"
+HOMEPAGE="https://github.com/apankrat/bff"
+SRC_URI="https://github.com/apankrat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~x86"
+IUSE="test"
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ # Makefile is not nice
+ emake -f /dev/null CC="$(tc-getCC)" bff
+}
+
+src_test() {
+ ebegin "Running mandelbrot test"
+ ./bff samples/mandelbrot.b > mandelbrot.out
+ eend $? || die
+ md5sum -c <<< '5024283fa65866ddd347b877798e84d8 mandelbrot.out' \
+ && cat mandelbrot.out \
+ || die "mandelbrot did not output correctly"
+}
+
+src_install() {
+ dobin bff
+}