summaryrefslogtreecommitdiff
path: root/dev-lang/bff/bff-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-lang/bff/bff-1.0.5.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lang/bff/bff-1.0.5.ebuild')
-rw-r--r--dev-lang/bff/bff-1.0.5.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-lang/bff/bff-1.0.5.ebuild b/dev-lang/bff/bff-1.0.5.ebuild
deleted file mode 100644
index ee9b8d706a87..000000000000
--- a/dev-lang/bff/bff-1.0.5.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="A brainfuck interpreter"
-HOMEPAGE="https://github.com/apankrat/bff"
-SRC_URI="https://github.com/apankrat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm ia64 m68k ppc ppc64 s390 sh x86"
-IUSE="test"
-
-DEPEND=""
-RDEPEND=""
-
-src_compile() {
- # Makefile is not nice
- emake -f /dev/null CC="$(tc-getCC)" bff
-}
-
-src_test() {
- ebegin "Running mandelbrot test"
- ./bff samples/mandelbrot.b > mandelbrot.out
- eend $? || die
- md5sum -c <<< '5024283fa65866ddd347b877798e84d8 mandelbrot.out' \
- && cat mandelbrot.out \
- || die "mandelbrot did not output correctly"
-}
-
-src_install() {
- dobin bff
-}