summaryrefslogtreecommitdiff
path: root/dev-lang/bas/bas-2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-lang/bas/bas-2.4.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-lang/bas/bas-2.4.ebuild')
-rw-r--r--dev-lang/bas/bas-2.4.ebuild32
1 files changed, 17 insertions, 15 deletions
diff --git a/dev-lang/bas/bas-2.4.ebuild b/dev-lang/bas/bas-2.4.ebuild
index 6e07253f7a6e..30a9f6103abf 100644
--- a/dev-lang/bas/bas-2.4.ebuild
+++ b/dev-lang/bas/bas-2.4.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit autotools eutils toolchain-funcs
+EAPI=7
+
+inherit autotools toolchain-funcs
DESCRIPTION="An interpreter for the classic dialect of the programming language BASIC"
HOMEPAGE="http://www.moria.de/~michael/bas/"
@@ -13,27 +14,28 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="lr0"
-RDEPEND="sys-libs/ncurses
+RDEPEND="
+ sys-libs/ncurses
virtual/libintl"
-DEPEND="${RDEPEND}
- sys-devel/gettext"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-2.1-makefile.patch
+PATCHES=( "${FILESDIR}"/${PN}-2.1-makefile.patch )
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
eautoconf
}
src_configure() {
tc-export AR
- econf \
- $(use_enable lr0)
+ econf $(use_enable lr0)
}
src_install() {
- emake DESTDIR="${D}" install
- dodoc NEWS README
- insinto /usr/share/doc/${PF}/pdf
- doins bas.pdf
+ default
+
+ docinto pdf
+ dodoc bas.pdf
}