summaryrefslogtreecommitdiff
path: root/dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.4.1.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.4.1.ebuild')
-rw-r--r--dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.4.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.4.1.ebuild b/dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.4.1.ebuild
new file mode 100644
index 000000000000..f0e3f45e98bc
--- /dev/null
+++ b/dev-lang/ammonite-repl-bin/ammonite-repl-bin-2.4.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+SCALA_VERSION="2.13"
+
+DESCRIPTION="Scala language-based scripting and REPL"
+HOMEPAGE="https://ammonite.io/"
+SRC_URI="https://github.com/lihaoyi/Ammonite/releases/download/${PV}/${SCALA_VERSION}-${PV} -> ammonite-${PV}"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+S="${WORKDIR}"
+
+RDEPEND=">=virtual/jre-1.8:*"
+
+src_install() {
+ newbin "${DISTDIR}/ammonite-${PV}" amm
+}