summaryrefslogtreecommitdiff
path: root/dev-lang/algol68g
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 16:50:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 16:50:39 +0100
commit3be8faef74cb863e207124a6fccbf01ce90c0799 (patch)
tree222958402b707645e8b7bcb072c607c538f2f5c0 /dev-lang/algol68g
parentea3e1bbf643d1d8892f4df05e4f05c1b2a2125d8 (diff)
gentoo auto-resync : 15:09:2023 - 16:50:39
Diffstat (limited to 'dev-lang/algol68g')
-rw-r--r--dev-lang/algol68g/Manifest4
-rw-r--r--dev-lang/algol68g/algol68g-3.3.21.ebuild41
-rw-r--r--dev-lang/algol68g/files/algol68g-3.3.21-configure-implicit.patch13
-rw-r--r--dev-lang/algol68g/metadata.xml20
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-lang/algol68g/Manifest b/dev-lang/algol68g/Manifest
new file mode 100644
index 000000000000..5d394b957368
--- /dev/null
+++ b/dev-lang/algol68g/Manifest
@@ -0,0 +1,4 @@
+AUX algol68g-3.3.21-configure-implicit.patch 236 BLAKE2B e59d1e65f6d1b83ac1bb43f00614d44ca13b0b2ad77fbc2da944b163487f679302e73d23bbe7d4adeb9a3168466bf38e53a38a3001b2e64725682f7e0edbbeac SHA512 11d9d38d98e210a2b20ef464ae365b4a1eab72befdb5daae15ad031cfda0d65f5d7134fe2c9c26d2929c172ebfef3acafd9072977c68a383784f2ccdefc41ff1
+DIST algol68g-3.3.21.tar.gz 660179 BLAKE2B 43f666cec1f77c3b7056221ab18bcc0bf458b6d6fe1d6c361709683993152aac6957068b09d8c47cc8441233739e7450ff126b1153bbbc272831c5200dde89a6 SHA512 18e3f431477fd282726858ae0b5abfe1f695a1f2ad9799437c0ce58808749c876067f2ccafc38b7baef392b1a7543fc389325dae0acfb60e19e2ef084423f719
+EBUILD algol68g-3.3.21.ebuild 947 BLAKE2B efe202e1c73de4a41a2462d1026512f6ce622cd4e3c4f3c4488660bcf1be9cbaec6b6fb5b01b16904fc1fe1d3be07921db0b8bc3ca591f02eada8416ceb3b0f4 SHA512 84428d78b17cfc764bcdbc8dbd5efe65cf631d01e25ccae803d3ba0af7f910bb8a01cfd7212fd303506dac017ad1f9bee325a79d7ed82e5e21ab9ec0a19bcfb5
+MISC metadata.xml 665 BLAKE2B 2b9b283f86666d64dd77164c5afb0d76403c63f9f0dfac3170eb2ade95bcc382b09d14248cb720edf7c1b055e78ca5ca0017b6784caf4381d970a011301058bd SHA512 b3171d505f9f9e4dcdd5b5a0c6d302849fa017538402832dd3db205c48c68a39867089aae4d1f3c158a45bfc170b21f83789cba16511f251d70300020e102b0a
diff --git a/dev-lang/algol68g/algol68g-3.3.21.ebuild b/dev-lang/algol68g/algol68g-3.3.21.ebuild
new file mode 100644
index 000000000000..f1c0cc53d018
--- /dev/null
+++ b/dev-lang/algol68g/algol68g-3.3.21.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Algol 68 Genie compiler-interpreter"
+HOMEPAGE="https://jmvdveer.home.xs4all.nl/en.algol-68-genie.html"
+SRC_URI="https://jmvdveer.home.xs4all.nl/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+curl +gsl +mpfr +ncurses plotutils postgres +readline"
+
+RDEPEND="
+ curl? ( net-misc/curl )
+ gsl? ( sci-libs/gsl:= )
+ mpfr? ( dev-libs/mpfr:= )
+ plotutils? ( media-libs/plotutils )
+ postgres? ( dev-db/postgresql:* )
+ readline? ( sys-libs/readline:= )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-3.3.21-configure-implicit.patch" )
+
+src_configure() {
+ local -a myconf=(
+ $(use_enable curl)
+ $(use_enable gsl)
+ $(use_enable mpfr)
+ $(use_enable ncurses curses)
+ $(use_enable plotutils)
+ $(use_enable postgres postgresql)
+ $(use_enable readline)
+ $(use_with ncurses)
+ )
+ econf "${myconf[@]}"
+}
diff --git a/dev-lang/algol68g/files/algol68g-3.3.21-configure-implicit.patch b/dev-lang/algol68g/files/algol68g-3.3.21-configure-implicit.patch
new file mode 100644
index 000000000000..4a8d96b1ad14
--- /dev/null
+++ b/dev-lang/algol68g/files/algol68g-3.3.21-configure-implicit.patch
@@ -0,0 +1,13 @@
+--- a/configure
++++ b/configure
+@@ -5568,6 +5568,10 @@ else $as_nop
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
++#include <gnu/libc-version.h>
++#include <stdlib.h>
++#include <stdio.h>
++
+ int
+ main (void)
+ {
diff --git a/dev-lang/algol68g/metadata.xml b/dev-lang/algol68g/metadata.xml
new file mode 100644
index 000000000000..146f78f15425
--- /dev/null
+++ b/dev-lang/algol68g/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Algol 68 Genie is free software distributed under the GNU General Public
+ License; it is a fast compiler-interpreter which ranks among the most
+ complete implementations of the language.
+ </longdescription>
+ <use>
+ <flag name="mpfr">Add support for multiprecision floating point rouding</flag>
+ </use>
+ <upstream>
+ <bugs-to>mailto:algol68g@xs4all.nl</bugs-to>
+ </upstream>
+</pkgmetadata>