summaryrefslogtreecommitdiff
path: root/dev-lang/R
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /dev-lang/R
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/Manifest1
-rw-r--r--dev-lang/R/R-4.1.2-r1.ebuild250
2 files changed, 251 insertions, 0 deletions
diff --git a/dev-lang/R/Manifest b/dev-lang/R/Manifest
index c40a1dc016d0..05f70eceb02f 100644
--- a/dev-lang/R/Manifest
+++ b/dev-lang/R/Manifest
@@ -8,5 +8,6 @@ DIST R-4.1.2.tar.gz 34009074 BLAKE2B 7ca14b28fc40548180dde979d57f93f41fb3966697d
DIST R-78d6830e28ea90a046da79a9b4f70c39594bb6d6.bash_completion 13596 BLAKE2B 53338e4a1c4f68beb69247216e553dbcac47f660fbf032bfebf7a660e32d2cff5b11ed35411c52de7e1fd6e00bbf5b5ea19369a325fa0a38bd93d63dc3288cbd SHA512 9ccd19bb1b0c18a2f13035ccd6809447429e197e298fb4d1df808ef345d723b42f75a1b91c349f6dbb46e4a82e59ef33e11300c495d79b63d670d0c0f2b16a06
EBUILD R-4.0.5-r1.ebuild 7313 BLAKE2B fd84cc2304d72deaf1f723bffed2906cbd810b913d4c636a37c12f4dab6ffa866ee769636bb700e2447a8a771dbed5cad9df3f289d510d9593f08f9c167f0a3f SHA512 50a086dade0562b6494623eb56f7fb2b98982a8d1b3d9f5ec27c35399ccf2de13c3c5a0ac51dc7d46abaac74d9838869aeeb274a7ac5120bfdc87c3a05354747
EBUILD R-4.1.0-r2.ebuild 7080 BLAKE2B 312412a327e25891d3b4236f648d4958b0d7ffcada36add367baeced3f325af645cb21c5126190643bfd92eba34d169c14a68e2cdfdc3b9c98de7e7254171e3b SHA512 978cf3808415dbcea5fcbf81a3e9877e236317bb89a821b2f812f0673631fee2e4be63a66c9b26ced3f85ef429ddca4482624e7e8d87b9c9172e87707d7325c8
+EBUILD R-4.1.2-r1.ebuild 7075 BLAKE2B 1eedcee7891e2aa3d28a34ea43e0020879ceecade6c8423cf2d4f2d0f057b427b70d661ee4411d7390639cb97177a2cf430e0653b682f70f9929b0f20e3929e5 SHA512 45f5570fe9ed2bcdd0898f673026cd1aba6d169d8109f47b01e91095ba849a2080c1260a40e5747e023f7fb2822fcadc69ed490cc2dc13ca2b9a3e8662e9fa66
EBUILD R-4.1.2.ebuild 7038 BLAKE2B 3e7ac8d5428f980703482a3ce4078aebbc9b983b7a80cb14f724f105473446ad5f235de6460ab2cf7b1c8d6699ddba755b63cad7edc21580aa070714c40e2af3 SHA512 fa144fa713a765892b8c9365aefe34b157f55f7e81aba0930188f9309363c1b6cca373d1e7335909310c4edb9781f2f572a4c552533d1187364ed41fb50d49a1
MISC metadata.xml 1261 BLAKE2B 468178b60e894bd8dff85ecbf74d10dce61bdb21fc8b61f43d7778dbc345234fc6b5e28c7608534d558c95fa6583b5acd2e55cef7096c4cff88e84776e93e03a SHA512 0d42cb1e3b951e3b1cbf09e6e48d47cf7635c8b16708b5b1edb6c5d1b422cad2f16ce5c6f7c603efb365eb9d5b794d2d2653b408147aa9e921cd57feb3840013
diff --git a/dev-lang/R/R-4.1.2-r1.ebuild b/dev-lang/R/R-4.1.2-r1.ebuild
new file mode 100644
index 000000000000..a4c36d76f9e3
--- /dev/null
+++ b/dev-lang/R/R-4.1.2-r1.ebuild
@@ -0,0 +1,250 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 autotools flag-o-matic fortran-2 toolchain-funcs
+
+# latest git commit for R bash completion: https://github.com/deepayan/rcompletion
+BCPV=78d6830e28ea90a046da79a9b4f70c39594bb6d6
+
+DESCRIPTION="Language and environment for statistical computing and graphics"
+HOMEPAGE="https://www.r-project.org/"
+SRC_URI="
+ mirror://cran/src/base/R-4/${P}.tar.gz
+ https://raw.githubusercontent.com/deepayan/rcompletion/${BCPV}/bash_completion/R -> ${PN}-${BCPV}.bash_completion"
+
+LICENSE="|| ( GPL-2 GPL-3 ) LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="cairo doc icu java jpeg lapack lto minimal nls openmp perl png prefix profile readline test tiff tk X"
+
+REQUIRED_USE="
+ png? ( || ( cairo X ) )
+ jpeg? ( || ( cairo X ) )
+ tiff? ( || ( cairo X ) )"
+RESTRICT="
+ minimal? ( test )
+ !test? ( test )"
+
+# At least one package installation in the test suite requires TeX,
+# and will fail without it (bug #718056).
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-fontsrecommended
+ )
+ test? ( virtual/latex-base )"
+DEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ app-text/ghostscript-gpl
+ dev-libs/libpcre2:=
+ >=dev-libs/tre-0.8.0_p20210321[approx]
+ net-libs/libtirpc
+ net-misc/curl
+ virtual/blas
+ sys-libs/zlib[minizip]
+ || (
+ sys-apps/coreutils
+ app-misc/realpath
+ )
+ cairo? (
+ x11-libs/cairo:=[X=]
+ x11-libs/pango:=
+ )
+ icu? ( dev-libs/icu:= )
+ jpeg? ( virtual/jpeg )
+ lapack? ( virtual/lapack )
+ perl? ( dev-lang/perl )
+ png? ( media-libs/libpng:= )
+ readline? ( sys-libs/readline:= )
+ tiff? ( media-libs/tiff:= )
+ tk? ( dev-lang/tk:= )
+ X? (
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-misc/xdg-utils
+ )"
+RDEPEND="${DEPEND}
+ java? ( >=virtual/jre-1.8:* )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.4.1-parallel.patch
+ "${FILESDIR}"/${PN}-3.4.1-rmath-shared.patch
+ "${FILESDIR}"/${PN}-3.6.2-no-LDFLAGS-in-libR-pkg-config.patch
+ "${FILESDIR}"/${PN}-3.6.2-no-gzip-doc.patch
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ FORTRAN_NEED_OPENMP=1
+ fi
+
+ fortran-2_pkg_setup
+
+ # avoid using existing R installation
+ unset R_HOME
+}
+
+src_prepare() {
+# rm -r src/extra/tre || die
+
+ default
+
+ # fix packages.html for doc (gentoo bug #205103)
+ sed -e "s:../../../library:../../../../$(get_libdir)/R/library:g" \
+ -i src/library/tools/R/Rd.R || die
+
+ # fix Rscript path when installed (gentoo bug #221061)
+ sed -e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${EPREFIX}/usr/$(get_libdir)/${PN}\"':" \
+ -i src/unix/Makefile.in || die "sed unix Makefile failed"
+
+ # fix HTML links to manual (gentoo bug #273957)
+ sed -e 's:\.\./manual/:manual/:g' \
+ -i $(grep -Flr ../manual/ doc) || die "sed for HTML links failed"
+
+ use lapack && \
+ export LAPACK_LIBS="$($(tc-getPKG_CONFIG) --libs lapack)"
+
+ if use X; then
+ export R_BROWSER="$(type -p xdg-open)"
+ export R_PDFVIEWER="$(type -p xdg-open)"
+ fi
+ use perl && \
+ export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
+
+ # don't search /usr/local
+ sed -i -e '/FLAGS=.*\/local\//c\: # removed by ebuild' configure.ac || die
+
+ # Fix for Darwin (macOS)
+ if use prefix; then
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -e 's:-install_name libR.dylib:-install_name ${libdir}/R/lib/libR.dylib:' \
+ -e 's:-install_name libRlapack.dylib:-install_name ${libdir}/R/lib/libRlapack.dylib:' \
+ -e 's:-install_name libRblas.dylib:-install_name ${libdir}/R/lib/libRblas.dylib:' \
+ -e "/SHLIB_EXT/s/\.so/.dylib/" \
+ -i configure.ac || die
+ # sort of "undo" 2.14.1-rmath-shared.patch
+ sed -e "s:-Wl,-soname=libRmath.so:-install_name ${EPREFIX}/usr/$(get_libdir)/libRmath.dylib:" \
+ -i src/nmath/standalone/Makefile.in || die
+ else
+ append-ldflags -Wl,-rpath="${EPREFIX}/usr/$(get_libdir)/R/lib"
+ fi
+ fi
+
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+ filter-ldflags -Wl,-Bdirect -Bdirect
+
+ econf \
+ --enable-byte-compiled-packages \
+ --enable-R-shlib \
+ --disable-R-framework \
+ --disable-R-static-lib \
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
+ rdocdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --with-system-tre \
+ $(use_enable java) \
+ $(use_enable lto lto R) \
+ $(use_enable nls) \
+ $(use_enable openmp) \
+ $(use_enable profile R-profiling) \
+ $(use_enable profile memory-profiling) \
+ $(use_with cairo) \
+ $(use_with icu ICU) \
+ $(use_with jpeg jpeglib) \
+ $(use_with lapack) \
+ $(use_with !minimal recommended-packages) \
+ $(use_with png libpng) \
+ $(use_with readline) \
+ $(use_with tiff libtiff) \
+ $(use_with tk tcltk) \
+ $(use_with tk tk-config "${ESYSROOT}"/usr/$(get_libdir)/tkConfig.sh) \
+ $(use_with tk tcl-config "${ESYSROOT}"/usr/$(get_libdir)/tclConfig.sh) \
+ $(use_with X x)
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}"/fonts
+ emake AR="$(tc-getAR)"
+ emake -C src/nmath/standalone shared AR="$(tc-getAR)"
+ use doc && emake info pdf
+}
+
+src_install() {
+ default
+ emake -j1 -C src/nmath/standalone DESTDIR="${D}" install
+
+ if use doc; then
+ emake DESTDIR="${D}" install-info install-pdf
+ dosym ../manual /usr/share/doc/${PF}/html/manual
+ fi
+
+ newenvd - 99R <<-_EOF_
+ LDPATH=${EPREFIX}/usr/$(get_libdir)/${PN}/lib
+ R_HOME=${EPREFIX}/usr/$(get_libdir)/${PN}
+ _EOF_
+
+ newbashcomp "${DISTDIR}"/${PN}-${BCPV}.bash_completion ${PN}
+ # The buildsystem has a different understanding of install_names than
+ # we require. Since it builds modules like shared objects (wrong), many
+ # objects (all modules) get an incorrect install_name. Fixing the build
+ # system here is not really trivial.
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ local mod
+ pushd "${ED}"/usr/$(get_libdir)/R >/dev/null || die
+ for mod in $(find . -name "*.dylib") ; do
+ mod=${mod#./}
+ install_name_tool -id "${EPREFIX}/usr/$(get_libdir)/R/${mod}" \
+ "${mod}"
+ done
+ popd >/dev/null || die
+ fi
+
+ # Users are encouraged to access some of the the R documentation
+ # interactively, through functions like "contributors()" that
+ # tries to open the "AUTHORS" file. Other files can be accessed
+ # by name with RShowDoc(), and the documentation for e.g. license()
+ # and RShowDoc() suggests a few of these names. Here we try to
+ # collect as many names as possible that a user might actually
+ # try to view through R, because if we don't decompress them,
+ # then R doesn't know what to do with 'em. Bug #556706.
+ local INTERACTIVE_DOCS=(
+ AUTHORS
+ COPYING
+ FAQ
+ NEWS
+ THANKS
+ )
+
+ # Other data sources that are shipped as "documentation," but which
+ # need to be accessible via their original unmolested filenames.
+ local INTERACTIVE_DATA=(
+ BioC_mirrors.csv
+ CRAN_mirrors.csv
+ KEYWORDS.db
+ NEWS.rds
+ )
+
+ local f NOCOMPRESS_DOCS=( "${INTERACTIVE_DOCS[@]}" "${INTERACTIVE_DATA[@]}" )
+
+ for f in "${NOCOMPRESS_DOCS[@]}"; do
+ docompress -x "/usr/share/doc/${PF}/${f}"
+ done
+}
+
+pkg_postinst() {
+ if use java; then
+ einfo "Re-initializing java paths for ${P}"
+ R CMD javareconf
+ fi
+}