summaryrefslogtreecommitdiff
path: root/dev-lang/R/files/R-3.4.1-rmath-shared.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-lang/R/files/R-3.4.1-rmath-shared.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-lang/R/files/R-3.4.1-rmath-shared.patch')
-rw-r--r--dev-lang/R/files/R-3.4.1-rmath-shared.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-lang/R/files/R-3.4.1-rmath-shared.patch b/dev-lang/R/files/R-3.4.1-rmath-shared.patch
new file mode 100644
index 000000000000..8bc6233de6df
--- /dev/null
+++ b/dev-lang/R/files/R-3.4.1-rmath-shared.patch
@@ -0,0 +1,21 @@
+--- a/src/nmath/standalone/Makefile.in 2017-07-05 23:20:26.098087600 +0000
++++ b/src/nmath/standalone/Makefile.in 2017-07-05 23:21:55.087480310 +0000
+@@ -64,7 +64,8 @@
+ Rexeclibdir_LTLIBRARIES = $(libRmath_la)
+ libRmath_la_SOURCES = $(SOURCES)
+ libRmath_la_OBJECTS = $(OBJECTS:.o=.lo)
+-libRmath_la_LDFLAGS =
++libRmath_la_LDFLAGS = -Wl,-soname=libRmath.so
++libRmath_la_LIBADD = $(LIBM)
+
+ CLEANFILES = Makedeps *.d *.o *.lo test check.log $(SOURCES)
+ DISTCLEANFILES = Makefile $(Rexeclibdir_LIBRARIES) $(Rexeclibdir_LTLIBRARIES)
+@@ -127,7 +128,7 @@
+
+ ## under peculiar circumstances, $(LIBM) here helps.
+ $(libRmath_la): $(libRmath_la_OBJECTS)
+- $(DYLIB_LINK) -o $@ $(libRmath_la_LDFLAGS) $(libRmath_la_OBJECTS) $(LIBM)
++ $(DYLIB_LINK) $(libRmath_la_LDFLAGS) $(libRmath_la_OBJECTS) $(libRmath_la_LIBADD) -o $@
+
+ test: $(srcdir)/test.c
+ $(CC) -o $@ $(ALL_CPPFLAGS) $(ALL_CFLAGS) $(srcdir)/test.c \