summaryrefslogtreecommitdiff
path: root/dev-java
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-05 00:07:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-05 00:07:53 +0100
commit9d1e33edaf09cde926d589461f40e378d4124be9 (patch)
treeb0a5a85acd92ce912a95245121dde9cebcf76b71 /dev-java
parentdafa6f367240d1f5329ca89fb6f78985dbdc025b (diff)
gentoo auto-resync : 05:06:2024 - 00:07:52
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/Manifest.gzbin55198 -> 55202 bytes
-rw-r--r--dev-java/httpcomponents-client/Manifest3
-rw-r--r--dev-java/httpcomponents-client/httpcomponents-client-4.5.13-r1.ebuild74
-rw-r--r--dev-java/httpcomponents-client/httpcomponents-client-4.5.13-r2.ebuild69
4 files changed, 71 insertions, 75 deletions
diff --git a/dev-java/Manifest.gz b/dev-java/Manifest.gz
index 341cdbbd6c1b..1a15b0a102cd 100644
--- a/dev-java/Manifest.gz
+++ b/dev-java/Manifest.gz
Binary files differ
diff --git a/dev-java/httpcomponents-client/Manifest b/dev-java/httpcomponents-client/Manifest
index e614f2b9c877..cc7cbc06ae2b 100644
--- a/dev-java/httpcomponents-client/Manifest
+++ b/dev-java/httpcomponents-client/Manifest
@@ -1,3 +1,4 @@
DIST httpcomponents-client-4.5.13-src.tar.gz 824131 BLAKE2B 1507c81749a92afcf8b170b606761236d71b02d8b8b257d753a0f09abbdc297057df39661e827dee52804a2138de7d201b2a837418cbec21085fd3ffd558b51c SHA512 421e413fb2206fa95b6428ff067cdf2b440d2d3d4503cc3ca9bcf70ccd8ed1b8273ec4fe0703e6a8cd7612940b7ed966d9f163dbfeb8bf699ae2a8b2e0866d05
-EBUILD httpcomponents-client-4.5.13-r1.ebuild 2233 BLAKE2B 88901103428958896b76bf6e18122742a6ab0151ddeed41b5c68e88efe8d5cb3c498a5d602f7f7aac1e5936ff7bf612be9fc1d478411d31db5334a56430c5133 SHA512 13d999d5d34e82f97d0fc3bfc85ce0e67b18614e31d2be1a1c38f815fcbe673553c8fd47cd6ec743a52737b8a77e0bd64abcdf448a98ca6b7b88bb79e5a25f3d
+DIST httpcomponents-client-4.5.13-src.tar.gz.asc 183 BLAKE2B 76b19170412672c8f4f30bcf96e1512ada5c6217a62ac1937d53c99223d687b363dc276365f2b0b6cd57abfd9d7d3a829e58f9c634081d84f05b558a61806402 SHA512 2af6ec691f0ebe6ceec4ca462e12638c8cfdb238fb4120195db1d9faca255b41119b6ddf34734ae29333256c91e1a0f1805192c0a2f1206093226e56e846cfc9
+EBUILD httpcomponents-client-4.5.13-r2.ebuild 2021 BLAKE2B 669fd6666de2719df82bde6eed35d0ae56db41f9d08ea917bdfeb1f831ce09560fcbda75256739654c65af2d20cba70a9277d130d79040699dd3507eb34283a4 SHA512 b4217479fe09aa4ab1e62a5f8f1530eb29eb8071c6b50db57baf47782d60749d6e0dcb25451e5a57c526fbf7baf628e34a3041baed56eba19ff8cb3b76228af3
MISC metadata.xml 310 BLAKE2B b068de1d99141665479706b2ee3af6195a1eb34cb7a063d2dd51434b4a5c6bbff26a06c94436fd352fd079cfa9ac6a9364cbf379991e803d771c04bdb9e12294 SHA512 26ec17ca1d7ccc803139a9f17dc51ef9cdf8e0bc697f0442c1718dd1807460add3d0560cd8f10ba2234f8e32990b922428b5903c0acfcd7d5e815dc9ba11280d
diff --git a/dev-java/httpcomponents-client/httpcomponents-client-4.5.13-r1.ebuild b/dev-java/httpcomponents-client/httpcomponents-client-4.5.13-r1.ebuild
deleted file mode 100644
index 5c35d1fb5ad7..000000000000
--- a/dev-java/httpcomponents-client/httpcomponents-client-4.5.13-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom httpcomponents-client-4.5.13/httpclient/pom.xml --download-uri https://github.com/apache/httpcomponents-client/archive/refs/tags/rel/v4.5.13.tar.gz --slot 4 --keywords "~amd64 ~ppc64 ~x86" --ebuild commons-httpclient-4.5.13.ebuild
-
-EAPI=7
-
-JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="org.apache.httpcomponents:httpclient:4.5.13"
-JAVA_TESTING_FRAMEWORKS="junit-4"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Apache HttpComponents Client"
-HOMEPAGE="https://hc.apache.org/httpcomponents-client"
-SRC_URI="mirror://apache/httpcomponents/httpclient/source/httpcomponents-client-${PV}-src.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="4"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-
-# Common dependencies
-# POM: httpcomponents-client-${PV}/httpclient/pom.xml
-# commons-codec:commons-codec:1.11 -> >=dev-java/commons-codec-1.15:0
-# commons-logging:commons-logging:1.2 -> >=dev-java/commons-logging-1.2:0
-# org.apache.httpcomponents:httpcore:4.4.13 -> >=dev-java/httpcore-4.4.14:0
-
-CDEPEND="
- dev-java/commons-codec:0
- dev-java/commons-logging:0
- dev-java/httpcore:0
-"
-
-# Compile dependencies
-# POM: httpcomponents-client-${PV}/httpclient/pom.xml
-# test? junit:junit:4.11 -> >=dev-java/junit-4.13.2:4
-# test? org.mockito:mockito-core:1.10.19 -> >=dev-java/mockito-1.9.5:0
-
-DEPEND="${CDEPEND}
- >=virtual/jdk-1.8:*
- test? (
- dev-java/hamcrest-core:1.3
- dev-java/mockito:0
- )"
-
-RDEPEND="${CDEPEND}
- >=virtual/jre-1.8:*"
-
-DOCS=( ../{LICENSE,NOTICE,README,RELEASE_NOTES}.txt )
-
-S="${WORKDIR}/httpcomponents-client-${PV}/httpclient"
-
-JAVA_GENTOO_CLASSPATH="commons-codec,commons-logging,httpcore"
-JAVA_SRC_DIR=(
- "src/main/java"
- "src/main/java-deprecated"
-)
-JAVA_RESOURCE_DIRS="src/main/resources"
-
-JAVA_TEST_GENTOO_CLASSPATH="junit-4,mockito,hamcrest-core-1.3"
-JAVA_TEST_SRC_DIR="src/test/java"
-JAVA_TEST_RESOURCE_DIRS="src/test/resources"
-
-JAVA_TEST_EXCLUDES=(
- # Tests run: 929, Failures: 1
- # javax.net.ssl.SSLHandshakeException: Remote host terminated the handshake
- "org.apache.http.conn.ssl.TestSSLSocketFactory"
-)
-
-src_install() {
- default
- java-pkg-simple_src_install
-}
diff --git a/dev-java/httpcomponents-client/httpcomponents-client-4.5.13-r2.ebuild b/dev-java/httpcomponents-client/httpcomponents-client-4.5.13-r2.ebuild
new file mode 100644
index 000000000000..2b074d240ff4
--- /dev/null
+++ b/dev-java/httpcomponents-client/httpcomponents-client-4.5.13-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="org.apache.httpcomponents:httpclient:${PV}"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple verify-sig
+
+DESCRIPTION="Apache HttpComponents Client"
+HOMEPAGE="https://hc.apache.org/httpcomponents-client-5.2.x/"
+SRC_URI="mirror://apache/httpcomponents/httpclient/source/${P}-src.tar.gz
+ verify-sig? ( https://downloads.apache.org/httpcomponents/httpclient/source/${P}-src.tar.gz.asc )"
+S="${WORKDIR}/httpcomponents-client-${PV}/httpclient"
+
+LICENSE="Apache-2.0"
+SLOT="4"
+KEYWORDS="amd64 ~arm arm64 ppc64 x86"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/openpgp-keys/httpcomponents-client.hc.apache.org.asc"
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-apache-httpcomponents-client )"
+
+CDEPEND="
+ dev-java/commons-codec:0
+ dev-java/commons-logging:0
+ dev-java/httpcore:0
+"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.8:*
+ test? (
+ dev-java/hamcrest-core:1.3
+ dev-java/mockito:0
+ )"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.8:*"
+
+DOCS=( ../{NOTICE,README,RELEASE_NOTES}.txt )
+
+JAVA_GENTOO_CLASSPATH="commons-codec,commons-logging,httpcore"
+JAVA_SRC_DIR=(
+ "src/main/java"
+ "src/main/java-deprecated"
+)
+JAVA_RESOURCE_DIRS="src/main/resources"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4,mockito,hamcrest-core-1.3"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS="src/test/resources"
+
+JAVA_TEST_EXCLUDES=(
+ # Tests run: 929, Failures: 1
+ # javax.net.ssl.SSLHandshakeException: Remote host terminated the handshake
+ "org.apache.http.conn.ssl.TestSSLSocketFactory"
+)
+
+src_test() {
+ # https://bugs.gentoo.org/923602
+ local vm_version="$(java-config -g PROVIDES_VERSION)"
+ if ver_test "${vm_version}" -ge "17" ; then
+ JAVA_TEST_EXTRA_ARGS+=( --add-opens=java.base/java.lang=ALL-UNNAMED )
+ JAVA_TEST_EXTRA_ARGS+=( --add-opens=java.base/java.net=ALL-UNNAMED )
+ JAVA_TEST_EXTRA_ARGS+=( --add-opens=java.base/java.io=ALL-UNNAMED )
+ fi
+ java-pkg-simple_src_test
+}