summaryrefslogtreecommitdiff
path: root/dev-java/xerces/xerces-2.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/xerces/xerces-2.11.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/xerces/xerces-2.11.0.ebuild')
-rw-r--r--dev-java/xerces/xerces-2.11.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-java/xerces/xerces-2.11.0.ebuild b/dev-java/xerces/xerces-2.11.0.ebuild
new file mode 100644
index 000000000000..005197c35e05
--- /dev/null
+++ b/dev-java/xerces/xerces-2.11.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit eutils versionator java-pkg-2 java-ant-2
+
+DIST_PN="Xerces-J"
+SRC_PV="$(replace_all_version_separators _ )"
+DESCRIPTION="The next generation of high performance, fully compliant XML parsers"
+HOMEPAGE="http://xml.apache.org/xerces2-j/index.html"
+SRC_URI="mirror://apache/${PN}/j/${DIST_PN}-src.${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="amd64 ~arm ppc64 x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# they are missing from the upstream tarball"
+RESTRICT="test"
+
+COMMON_DEP="
+ dev-java/xml-commons-external:1.4
+ >=dev-java/xml-commons-resolver-1.2:0"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.4"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.4
+ >=dev-java/xjavac-20110814:1"
+
+S="${WORKDIR}/${PN}-${SRC_PV}"
+
+java_prepare() {
+ epatch "${FILESDIR}/${P}-build.xml.patch"
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+JAVA_ANT_CLASSPATH_TAGS+=" javadoc"
+
+EANT_ANT_TASKS="xjavac-1"
+EANT_GENTOO_CLASSPATH="xml-commons-resolver,xml-commons-external-1.4"
+EANT_DOC_TARGET="javadocs"
+# known small bug - javadocs use custom taglets, which come as bundled jar in
+# xerces-J-tools.${PV}.tar.gz. Should find the taglets source instead.
+EANT_EXTRA_ARGS="-Dadditional.param="
+
+src_install() {
+ java-pkg_dojar build/xercesImpl.jar
+
+ dodoc README NOTICE
+ dohtml Readme.html
+
+ use doc && java-pkg_dojavadoc build/docs/javadocs/xerces2
+ use examples && java-pkg_doexamples samples
+ use source && java-pkg_dosrc src/org
+}