summaryrefslogtreecommitdiff
path: root/dev-java/wsdl4j/wsdl4j-1.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /dev-java/wsdl4j/wsdl4j-1.6.2.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'dev-java/wsdl4j/wsdl4j-1.6.2.ebuild')
-rw-r--r--dev-java/wsdl4j/wsdl4j-1.6.2.ebuild34
1 files changed, 18 insertions, 16 deletions
diff --git a/dev-java/wsdl4j/wsdl4j-1.6.2.ebuild b/dev-java/wsdl4j/wsdl4j-1.6.2.ebuild
index 0c4ab5f3f3c5..671b3781782a 100644
--- a/dev-java/wsdl4j/wsdl4j-1.6.2.ebuild
+++ b/dev-java/wsdl4j/wsdl4j-1.6.2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
JAVA_PKG_IUSE="doc source test"
-inherit versionator java-pkg-2 java-ant-2
+inherit java-pkg-2 java-ant-2
DESCRIPTION="Web Services Description Language for Java Toolkit (WSDL4J)"
HOMEPAGE="http://wsdl4j.sourceforge.net"
@@ -19,35 +19,37 @@ SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.zip
LICENSE="CPL-1.0"
SLOT="0"
KEYWORDS="amd64 ~ppc64 x86"
+# tests fail with encoding errors
+RESTRICT="test"
DEPEND=">=virtual/jdk-1.4
- test? ( =dev-java/junit-3.8* )
+ test? ( dev-java/junit:0 )
app-arch/unzip"
RDEPEND=">=virtual/jre-1.4"
-S="${WORKDIR}/${PN}-$(replace_all_version_separators _)"
-TCK_S="${WORKDIR}/${TCK}-$(replace_all_version_separators _ ${TCK_V})"
+S="${WORKDIR}/${P//./_}"
+TCK_S="${WORKDIR}/${TCK}-${TCK_V//./_}"
-src_unpack() {
- unpack ${A}
+EANT_BUILD_TARGET="compile"
+EANT_DOC_TARGET="javadocs"
+
+src_prepare() {
+ default
if use test; then
rm -v "${TCK_S}"/lib/*.jar || die
- epatch "${FILESDIR}/1.6.2-tests-sandbox.patch"
+ eapply "${FILESDIR}/1.6.2-tests-sandbox.patch"
fi
}
-EANT_BUILD_TARGET="compile"
-EANT_DOC_TARGET="javadocs"
-
src_test() {
- ln -s "${TCK_S}" test
- cd "${TCK_S}"
+ ln -s "${TCK_S}" test || die
+ cd "${TCK_S}" || die
java-ant_rewrite-classpath
local junit="$(java-pkg_getjars junit)"
eant -Dbuild.lib="${S}/test/lib" compile \
-Dgentoo.classpath="${S}/build/lib/${PN}.jar:${junit}"
- cd "${S}"
- mkdir "${T}/lib"
+ cd "${S}" || die
+ mkdir "${T}/lib" || die
ANT_TASKS="ant-junit" eant test -Dtemp.dir="${T}"
}