summaryrefslogtreecommitdiff
path: root/dev-java/tomcat-native/tomcat-native-1.2.19.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /dev-java/tomcat-native/tomcat-native-1.2.19.ebuild
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'dev-java/tomcat-native/tomcat-native-1.2.19.ebuild')
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.2.19.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-java/tomcat-native/tomcat-native-1.2.19.ebuild b/dev-java/tomcat-native/tomcat-native-1.2.19.ebuild
deleted file mode 100644
index fb46a0bf4e2e..000000000000
--- a/dev-java/tomcat-native/tomcat-native-1.2.19.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Allows Tomcat to use certain native resources for better performance"
-HOMEPAGE="https://tomcat.apache.org/"
-SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
-
-KEYWORDS="amd64 ~x86"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="static-libs test"
-
-RDEPEND="dev-libs/apr:1=
- dev-libs/openssl:0=
- >=virtual/jre-1.8"
-
-DEPEND=">=virtual/jdk-1.8
- test? ( dev-java/ant-junit:0 )"
-
-S=${WORKDIR}/${P}-src
-
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-
-src_configure() {
- local myeconfargs=(
- --with-apr="${EPREFIX}"/usr/bin/apr-1-config
- --with-ssl="${EPREFIX}"/usr
- )
-
- cd native || die
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- eant jar
-
- cd native || die
- default
-}
-
-src_install() {
- java-pkg_newjar "dist/${P}.jar" "${PN}.jar"
-
- cd native || die
- default
-
- ! use static-libs && find "${D}" -name '*.la' -delete || die
-}
-
-src_test() {
- java-pkg-2_src_test
-}
-
-pkg_postinst() {
- elog "For more information, please visit"
- elog "https://tomcat.apache.org/tomcat-9.0-doc/apr.html"
-}