summaryrefslogtreecommitdiff
path: root/dev-java/super-csv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/super-csv
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/super-csv')
-rw-r--r--dev-java/super-csv/Manifest4
-rw-r--r--dev-java/super-csv/files/super-csv-2.3.1-build.xml235
-rw-r--r--dev-java/super-csv/metadata.xml15
-rw-r--r--dev-java/super-csv/super-csv-2.3.1.ebuild41
4 files changed, 295 insertions, 0 deletions
diff --git a/dev-java/super-csv/Manifest b/dev-java/super-csv/Manifest
new file mode 100644
index 000000000000..09848eaa116e
--- /dev/null
+++ b/dev-java/super-csv/Manifest
@@ -0,0 +1,4 @@
+AUX super-csv-2.3.1-build.xml 10120 BLAKE2B 0a4cb4f3fac442c971a2572d5e251d33b304d817722baabdc72684a5ce5c698c20d689354789d555e033beb443fa2381a12595f301616a19bdfb809a415378be SHA512 c00ce7e07a0fc35de8bbe5de901eae64f42fa0d2b277ca54a4fc58474f7f57c4c091a214290acfaddac30bc8180f1a6b621aca67fe320c028f2623d87985b2c5
+DIST super-csv-2.3.1.zip 16624601 BLAKE2B 0d8b6f21f8f8b50dfb981bbce0e7012e85ea0b4512777da36094943ee6ce303c12c05e1c55d0e5c22cfd9b7c651723617dd83e58b301f3f041128f24e16faa3e SHA512 6b418e4875e5c553572fc8fbb8fac47f5bd9647aa6261bcb5115234b0d23ed606e88b862fe3203837ed389cb2216ab707909bb6ed1cd18297b8d481973170515
+EBUILD super-csv-2.3.1.ebuild 934 BLAKE2B 7f3717c03afafb272e96029c17be2f06da296bccd58e655625103102e5469f8b0412cafd2691c90588b416cc15d1fc729bccbaf434790db0a7cf0f0d04ec24a0 SHA512 419c92da25faa1c2813e2b42c744b16a889579db5a09bc1ab01a86eda95516f33db59dd2404b14f840b6f28e557b4f44f99a591cc07186542b78829c488cd1d0
+MISC metadata.xml 431 BLAKE2B 09f55578bcf6cfe8d966bd547b105e4b233cf7e90d79e418f2c2c9f6b7ef3c163921539b006f0ac01fe058c49bfdf6b9ca918322ed82060b5b7a4019b5eb4aff SHA512 64643e48ccc8537b92b7255824e10acb0ea09d273cd7ae1ea9d8ac110eca614acbb9e34c690e238c4f11caaa6d46175807ceffe1bf841f2b87005a0395acd84e
diff --git a/dev-java/super-csv/files/super-csv-2.3.1-build.xml b/dev-java/super-csv/files/super-csv-2.3.1-build.xml
new file mode 100644
index 000000000000..94a8f2125a29
--- /dev/null
+++ b/dev-java/super-csv/files/super-csv-2.3.1-build.xml
@@ -0,0 +1,235 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 10/14/15 7:02 AM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="super-csv" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="super-csv-2.3.1"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.11/junit-4.11.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present" classpathref="build.test.classpath"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in the test classpath or your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false">
+ <link href="http://java.sun.com/j2se/1.5.0/docs/api"/>
+ <link href="http://dozer.sourceforge.net/apidocs"/>
+ <link href="http://www.joda.org/joda-time/apidocs"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+</project>
diff --git a/dev-java/super-csv/metadata.xml b/dev-java/super-csv/metadata.xml
new file mode 100644
index 000000000000..4437de6dfc91
--- /dev/null
+++ b/dev-java/super-csv/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">super-csv/super-csv</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+<maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-java/super-csv/super-csv-2.3.1.ebuild b/dev-java/super-csv/super-csv-2.3.1.ebuild
new file mode 100644
index 000000000000..3b686ea92fca
--- /dev/null
+++ b/dev-java/super-csv/super-csv-2.3.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+JAVA_PKG_IUSE="source doc test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A fast, programmer-friendly, free CSV library for Java"
+HOMEPAGE="http://super-csv.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.zip -> ${P}.zip"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86"
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6
+ test? (
+ dev-java/ant-junit:0
+ )"
+
+IUSE=""
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_BUILD_TARGET="package"
+EANT_BUILD_XML="${PN}/build.xml"
+
+java_prepare() {
+ cp -v "${FILESDIR}/${P}-build.xml" "${S}/${PN}/build.xml" || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar "${PN}/target/${P}.jar" "${PN}.jar"
+ dodoc README.md
+ use doc && java-pkg_dojavadoc "${PN}/target/site/apidocs"
+ use source && java-pkg_dosrc "${PN}/src/main/java"
+}