summaryrefslogtreecommitdiff
path: root/dev-java/spec-alpha/spec-alpha-0.1.143.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-java/spec-alpha/spec-alpha-0.1.143.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-java/spec-alpha/spec-alpha-0.1.143.ebuild')
-rw-r--r--dev-java/spec-alpha/spec-alpha-0.1.143.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-java/spec-alpha/spec-alpha-0.1.143.ebuild b/dev-java/spec-alpha/spec-alpha-0.1.143.ebuild
new file mode 100644
index 000000000000..d4a4e473b091
--- /dev/null
+++ b/dev-java/spec-alpha/spec-alpha-0.1.143.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2 java-ant-2
+
+EGIT_REF="51b64c0"
+
+MY_PN=${PN//-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A Clojure library to describe the structure of data and functions."
+HOMEPAGE="https://clojure.org/ https://github.com/clojure/spec.alpha"
+SRC_URI="https://github.com/clojure/${MY_PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0.1"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+IUSE=""
+
+CDEPEND="dev-java/ant-core:0"
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.8:*"
+
+S="${WORKDIR}/${MY_PN}-${MY_P}"
+
+EANT_TASKS="jar"
+EANT_EXTRA_ARGS="-Dmaven.build.finalName=${MY_P}"
+
+src_prepare() {
+ default
+ cp "${FILESDIR}/build.xml" . || die
+}
+
+src_install() {
+ java-pkg_newjar "target/${MY_P}.jar"
+ dodoc CONTRIBUTING.md README.md
+}