summaryrefslogtreecommitdiff
path: root/dev-java/resin-servlet-api/resin-servlet-api-3.1.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/resin-servlet-api/resin-servlet-api-3.1.12.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/resin-servlet-api/resin-servlet-api-3.1.12.ebuild')
-rw-r--r--dev-java/resin-servlet-api/resin-servlet-api-3.1.12.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-java/resin-servlet-api/resin-servlet-api-3.1.12.ebuild b/dev-java/resin-servlet-api/resin-servlet-api-3.1.12.ebuild
new file mode 100644
index 000000000000..f0f872dfd98b
--- /dev/null
+++ b/dev-java/resin-servlet-api/resin-servlet-api-3.1.12.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Resin Servlet API 2.5/JSP API 2.1 implementation"
+HOMEPAGE="http://www.caucho.com/"
+SRC_URI="http://www.caucho.com/download/resin-${PV}-src.zip
+ mirror://gentoo/resin-gentoo-patches-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2.5"
+KEYWORDS="amd64 ppc64 x86"
+
+IUSE=""
+
+COMMON_DEP=""
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/resin-${PV}"
+
+src_prepare() {
+ mkdir -p "${S}/lib"
+ epatch "${WORKDIR}/${PV}/resin-${PV}-build.xml.patch"
+}
+
+EANT_BUILD_TARGET="jsdk"
+EANT_DOC_TARGET=""
+
+src_install() {
+ java-pkg_newjar "lib/jsdk-15.jar"
+ use source && java-pkg_dosrc "${S}"/modules/jsdk/src/*
+
+ dosym "${PN}.jar" "/usr/share/${PN}-${SLOT}/lib/servlet-api.jar"
+ java-pkg_regjar "${D}/usr/share/${PN}-${SLOT}/lib/servlet-api.jar"
+ dosym "${PN}.jar" "/usr/share/${PN}-${SLOT}/lib/jsp-api.jar"
+ java-pkg_regjar "${D}/usr/share/${PN}-${SLOT}/lib/jsp-api.jar"
+}