summaryrefslogtreecommitdiff
path: root/dev-java/relaxng-datatype/relaxng-datatype-1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/relaxng-datatype/relaxng-datatype-1.0-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/relaxng-datatype/relaxng-datatype-1.0-r2.ebuild')
-rw-r--r--dev-java/relaxng-datatype/relaxng-datatype-1.0-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/relaxng-datatype/relaxng-datatype-1.0-r2.ebuild b/dev-java/relaxng-datatype/relaxng-datatype-1.0-r2.ebuild
new file mode 100644
index 000000000000..e2bae382dc23
--- /dev/null
+++ b/dev-java/relaxng-datatype/relaxng-datatype-1.0-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+MY_PN="relaxngDatatype"
+MY_P="${MY_PN}-${PV}"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Interface between RELAX NG validators and datatype libraries"
+HOMEPAGE="http://relaxng.org/"
+SRC_URI="mirror://sourceforge/relaxng/${MY_P}.zip -> ${P}.zip"
+
+KEYWORDS="amd64 ~arm ~arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND=">=virtual/jdk-1.7"
+RDEPEND=">=virtual/jre-1.7"
+
+DOCS=( README.txt )
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ java-pkg_clean
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ einstalldocs
+}