summaryrefslogtreecommitdiff
path: root/dev-java/picocontainer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-java/picocontainer
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/picocontainer')
-rw-r--r--dev-java/picocontainer/Manifest3
-rw-r--r--dev-java/picocontainer/metadata.xml16
-rw-r--r--dev-java/picocontainer/picocontainer-1.1-r1.ebuild57
3 files changed, 0 insertions, 76 deletions
diff --git a/dev-java/picocontainer/Manifest b/dev-java/picocontainer/Manifest
deleted file mode 100644
index 16e97175829c..000000000000
--- a/dev-java/picocontainer/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST picocontainer-1.1-src.tar.gz 83564 BLAKE2B 193d042400e4509e82c8dd521fc4ee8a246f0b8111cd875810260d510bef08970ac632f3e81c370290e6074dcc75348af7db71abc9047e49b323910d03e932f4 SHA512 adee3e5f46cc8f9a57db1c3e08b4730430daf92c090413ce061576c272b0a1a8bad94281a7a0bd4bdfa8fec8ca051bd15560d0a0fb0ca65cee39ea5ff1b15777
-EBUILD picocontainer-1.1-r1.ebuild 1226 BLAKE2B cb70328dc89644a88856df59f1026df5e4094e8fa8b3858e97fa242c5d6a1ceca87959a8d300c6014d40ee05056b6f48702e9255b3b8540bc0bef52ec6d3dded SHA512 796faf47ab39e427be485acb6e8a38f079ede29cf29de36f5c43e43674688400f4f8e94c922b01d5bda542a1329d6f6230a8cb15ecb5d3fb123bcc3e5081cd44
-MISC metadata.xml 628 BLAKE2B 0a6d660b64c4a9bd642e3f990fd715e02037fe67526e0215631f65afdececeaea34486a166e7e5a4b811fa6e7494a90f685a3e27fd5df15c0e2071eff332aa9b SHA512 24a5b116cc43b3dbefa809f4ba45c50b08f5a3f8ad2db6a93fa8618e2f9dee6b1a09163d03b036f3ecad5f7f475748fac05c6ab213d61031942b9a0e24ba3cab
diff --git a/dev-java/picocontainer/metadata.xml b/dev-java/picocontainer/metadata.xml
deleted file mode 100644
index 7c03ea6b885a..000000000000
--- a/dev-java/picocontainer/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
-</maintainer>
-<longdescription>
-PicoContainer is very simple container for very simple components. It
-honors the Inversion of control pattern (IoC) in a way that we calling
-it type 3 IoC. See below for types. Components are typically going to
-live inside the same JVM. The idea is that this might scale from
-embedded containers for simple beans to enterprise and distributed
-applications.
-</longdescription>
-</pkgmetadata>
diff --git a/dev-java/picocontainer/picocontainer-1.1-r1.ebuild b/dev-java/picocontainer/picocontainer-1.1-r1.ebuild
deleted file mode 100644
index a49d6d45238c..000000000000
--- a/dev-java/picocontainer/picocontainer-1.1-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Small footprint Dependency Injection container"
-HOMEPAGE="http://www.picocontainer.org"
-SRC_URI="http://dist.codehaus.org/${PN}/distributions/${P}-src.tar.gz"
-
-LICENSE="BSD"
-SLOT="1"
-KEYWORDS="amd64 x86"
-IUSE="doc source"
-
-RDEPEND=">=virtual/jre-1.4"
-DEPEND=">=virtual/jdk-1.4
- >=dev-java/ant-core-1.5
- source? ( app-arch/zip )
- "
-# test? (
-# >=dev-java/junit-3.8.1
-# )"
-
-RESTRICT="test"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # Don't run tests automatically
- sed -i -e 's/compile,test/compile/' build.xml || die
-
-# doesn't pass internal test even when trying vanilla build.xml that fetches own libs
-# if use test ; then
-# mkdir -p target/lib
-# cd target/lib
-# java-pkg_jar-from junit junit-3.8.1.jar
-# fi
-}
-
-src_compile() {
- local antflags="-Dfinal.name=${PN} -Dnoget=true jar"
- eant ${antflags} $(use_doc)
-}
-
-#src_test() {
-# local antflags="-Dfinal.name=${PN} -Dnoget=true test"
-# eant ${antflags}
-#}
-
-src_install() {
- java-pkg_dojar target/${PN}.jar
-
- use doc && java-pkg_dojavadoc dist/docs/api
- use source && java-pkg_dosrc src/java/org
-}