summaryrefslogtreecommitdiff
path: root/dev-java/osgi-foundation/osgi-foundation-1.2.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-java/osgi-foundation/osgi-foundation-1.2.0-r2.ebuild
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-java/osgi-foundation/osgi-foundation-1.2.0-r2.ebuild')
-rw-r--r--dev-java/osgi-foundation/osgi-foundation-1.2.0-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-java/osgi-foundation/osgi-foundation-1.2.0-r2.ebuild b/dev-java/osgi-foundation/osgi-foundation-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..3e37ca69434e
--- /dev/null
+++ b/dev-java/osgi-foundation/osgi-foundation-1.2.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="OSGi R4 Foundation EE by Apache Felix"
+HOMEPAGE="http://felix.apache.org/"
+SRC_URI="https://dev.gentoo.org/~tomwij/files/dist/${P}.tar.xz"
+
+LICENSE="Apache-2.0 OSGi-Specification-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+src_prepare() {
+ default
+ cp "${FILESDIR}"/${P}-build.xml "${S}"/build.xml || die
+}
+
+src_install() {
+ java-pkg_newjar target/org.osgi.foundation-${PV}.jar org.osgi.foundation.jar
+}