summaryrefslogtreecommitdiff
path: root/dev-java/osgi-compendium/osgi-compendium-4.3.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-java/osgi-compendium/osgi-compendium-4.3.1-r2.ebuild
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-java/osgi-compendium/osgi-compendium-4.3.1-r2.ebuild')
-rw-r--r--dev-java/osgi-compendium/osgi-compendium-4.3.1-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-java/osgi-compendium/osgi-compendium-4.3.1-r2.ebuild b/dev-java/osgi-compendium/osgi-compendium-4.3.1-r2.ebuild
new file mode 100644
index 000000000000..f2cd70ced9b0
--- /dev/null
+++ b/dev-java/osgi-compendium/osgi-compendium-4.3.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="OSGi Service Platform Compendium API (Companion Code)"
+HOMEPAGE="http://wiki.osgi.org/wiki/Release_4.3"
+SRC_URI="https://osgi.org/download/r4v43/osgi.cmpn-${PV}.jar"
+
+LICENSE="Apache-2.0 OSGi-Specification-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 x86"
+
+CDEPEND="dev-java/glassfish-persistence:0
+ dev-java/osgi-core-api:0
+ dev-java/osgi-foundation:0
+ dev-java/tomcat-servlet-api:4.0"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.8:*"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.8:*"
+
+BDEPEND="app-arch/unzip"
+
+JAVA_SRC_DIR="OSGI-OPT/src"
+
+JAVA_GENTOO_CLASSPATH="
+ osgi-core-api
+ osgi-foundation
+ glassfish-persistence
+ tomcat-servlet-api-4.0
+"
+
+src_prepare() {
+ default
+ rm -r org || die
+}