summaryrefslogtreecommitdiff
path: root/dev-java/netty-tcnative
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-java/netty-tcnative
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-java/netty-tcnative')
-rw-r--r--dev-java/netty-tcnative/Manifest2
-rw-r--r--dev-java/netty-tcnative/netty-tcnative-2.0.31.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-java/netty-tcnative/Manifest b/dev-java/netty-tcnative/Manifest
index d33fb7794347..5e30a7322247 100644
--- a/dev-java/netty-tcnative/Manifest
+++ b/dev-java/netty-tcnative/Manifest
@@ -1,3 +1,5 @@
DIST netty-tcnative-1.1.33.Fork15.tar.gz 186153 BLAKE2B 3d769a04e659c09aa32059fc2a2eede84f6105469de33ef7d26df436de6a1f6290a6640268934f63f77a969eb6aa024651380cca6dc69099c4016ed61f7d5310 SHA512 592c70a926473a4903b704be920aac1a4fd5a032a8d821a77800b6922b374cb28decf496a65ef62867c027dbac93f0e563e9bb4ecf6659bc70cc33663bb979f5
+DIST netty-tcnative-parent-2.0.31.Final.tar.gz 175283 BLAKE2B 421b8228fb30da7f2983771e3c20e2442ae0c3ef8d12a139a7c01cb43056e916c889294622dbde04443382965750db0195dc667deb34ffcce998ef6381b54eb3 SHA512 0b11d6ec82636e8db09142d345df4b50dbbb7b7a2543f8e4e4d8793205fb22f2f631f454f70b78e93d24a9aeebe55098635c0e9d7a0daf1786b63fe3580aa236
EBUILD netty-tcnative-1.1.33.15.ebuild 1656 BLAKE2B c077032763915bf88dfb38701a85ccd5d7e38f1827282141dff9f8d10c079e7f3f76f433fcc220eea05985ab1712e6c09f4aaf92b10b24c5e8efaf13ed190732 SHA512 6191cd52dbb0efc90219d1167a5430ecc5afefe22ca21d5376e1c12a1bbc810e31f15b349f3e93d7745b1324a7389cf17adc0149c3d289fcd06f5dbc1d1b2bf6
+EBUILD netty-tcnative-2.0.31.ebuild 1677 BLAKE2B a8ebe60715a25d8b938358fbb24cc64f77cbca8b1bae183095bec9222eddb4ba33747256d3b4684116e51c8421df15a9e6c82e0ac2e5a713d456b3d39a3d329c SHA512 e4e87470af1ec798410fcf0759e18a42040eb1bbfaba41dcca659e5fec5176e8bc2fef06a0b37dd0a1d4f6294977871581dbdff6bad1fc1a21097bc2d8a162a3
MISC metadata.xml 321 BLAKE2B d5ef2b6901e18ae4fcbb63df20a62edbe59169783a0ae50553194b6e4760b421078ad26fefb1fe38527a71d2e0053b3ee24683e166660cdd2b8ca1d9e1b47d94 SHA512 cafd11002a29f2a3f485ea8c2abc2c338811c0c9e9f6fe416f089d545971b44dbd6490cdbf9c9f3be75fb1fbad56c533d9d3e6141721027545b6e1ae31bdddd5
diff --git a/dev-java/netty-tcnative/netty-tcnative-2.0.31.ebuild b/dev-java/netty-tcnative/netty-tcnative-2.0.31.ebuild
new file mode 100644
index 000000000000..da142b72aac4
--- /dev/null
+++ b/dev-java/netty-tcnative/netty-tcnative-2.0.31.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+
+inherit autotools java-pkg-2 java-pkg-simple
+
+MY_P="${PN}-parent-${PV}.Final"
+MAVEN_ID="io.netty:netty-tcnative:2.0.31"
+
+DESCRIPTION="Fork of Tomcat Native that incorporates various patches"
+HOMEPAGE="https://netty.io/wiki/forked-tomcat-native.html"
+SRC_URI="https://github.com/netty/netty-tcnative/archive/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-libs/apr:1=
+ dev-libs/openssl:0="
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.8"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.8
+ app-arch/unzip
+ dev-java/maven-hawtjni-plugin:0"
+
+S="${WORKDIR}/${PN}-${MY_P}"
+JAVA_SRC_DIR="${S}/openssl-dynamic/src/main/java"
+NATIVE_DIR="${S}/openssl-dynamic/src/main/native-package"
+
+src_prepare() {
+ default
+
+ cd "${NATIVE_DIR}" || die
+ ln -sn ../c src || die
+ ln -sn . project-template || die
+
+ # Provides missing m4 files and Makefile.am template.
+ unzip -n $(java-pkg_getjars --build-only maven-hawtjni-plugin) project-template/\* || die
+
+ sed -i \
+ -e "s:@PROJECT_NAME@:${PN}:g" \
+ -e "s:@PROJECT_NAME_UNDER_SCORE@:${PN//-/_}:g" \
+ -e "s:@PROJECT_SOURCES@:$(echo src/*.c):g" \
+ Makefile.am || die
+
+ # Avoid dummy version and tedious symlink.
+ sed -i "s/-release @VERSION@/-avoid-version/g" configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ cd "${NATIVE_DIR}" || die
+ econf --with-apr=/usr/bin/apr-1-config --with-ssl=/usr
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ emake -C "${NATIVE_DIR}"
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_doso "${NATIVE_DIR}"/.libs/lib${PN}.so
+ dodoc README.md
+}