summaryrefslogtreecommitdiff
path: root/dev-java/netty-tcnative
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-java/netty-tcnative
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/netty-tcnative')
-rw-r--r--dev-java/netty-tcnative/Manifest3
-rw-r--r--dev-java/netty-tcnative/metadata.xml11
-rw-r--r--dev-java/netty-tcnative/netty-tcnative-1.1.33.15.ebuild68
3 files changed, 0 insertions, 82 deletions
diff --git a/dev-java/netty-tcnative/Manifest b/dev-java/netty-tcnative/Manifest
deleted file mode 100644
index 7a0222187681..000000000000
--- a/dev-java/netty-tcnative/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST netty-tcnative-1.1.33.Fork15.tar.gz 186153 BLAKE2B 3d769a04e659c09aa32059fc2a2eede84f6105469de33ef7d26df436de6a1f6290a6640268934f63f77a969eb6aa024651380cca6dc69099c4016ed61f7d5310 SHA512 592c70a926473a4903b704be920aac1a4fd5a032a8d821a77800b6922b374cb28decf496a65ef62867c027dbac93f0e563e9bb4ecf6659bc70cc33663bb979f5
-EBUILD netty-tcnative-1.1.33.15.ebuild 1657 BLAKE2B 5bb72d18f8230cc0423b1909236284f0edf5290061b8b67052e11fde1328da4ab273943dedd7f3f4f416739631c8fa9eac5233f9fe931a7cb1fbb818c8875e8c SHA512 4a533c530136e2eb72bd6070515490e4a49898b1742ce8d986a367140ebba978c0d619727270d7a13a5aa9ee9ec4c19008d87447b8c7853045793cc2791eee20
-MISC metadata.xml 321 BLAKE2B d5ef2b6901e18ae4fcbb63df20a62edbe59169783a0ae50553194b6e4760b421078ad26fefb1fe38527a71d2e0053b3ee24683e166660cdd2b8ca1d9e1b47d94 SHA512 cafd11002a29f2a3f485ea8c2abc2c338811c0c9e9f6fe416f089d545971b44dbd6490cdbf9c9f3be75fb1fbad56c533d9d3e6141721027545b6e1ae31bdddd5
diff --git a/dev-java/netty-tcnative/metadata.xml b/dev-java/netty-tcnative/metadata.xml
deleted file mode 100644
index ab6637a0c595..000000000000
--- a/dev-java/netty-tcnative/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
- <upstream>
- <remote-id type="github">netty/netty-tcnative</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-java/netty-tcnative/netty-tcnative-1.1.33.15.ebuild b/dev-java/netty-tcnative/netty-tcnative-1.1.33.15.ebuild
deleted file mode 100644
index 395e9a7a95df..000000000000
--- a/dev-java/netty-tcnative/netty-tcnative-1.1.33.15.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc source"
-
-inherit autotools versionator java-pkg-2 java-pkg-simple
-
-MY_P="${PN}-$(replace_version_separator 3 .Fork)"
-
-DESCRIPTION="Fork of Tomcat Native that incorporates various patches"
-HOMEPAGE="http://netty.io/wiki/forked-tomcat-native.html"
-SRC_URI="https://github.com/netty/netty-tcnative/archive/${MY_P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-CDEPEND="dev-libs/apr:1=
- dev-libs/openssl:0="
-
-RDEPEND="${CDEPEND}
- >=virtual/jre-1.7"
-
-DEPEND="${CDEPEND}
- >=virtual/jdk-1.7
- app-arch/unzip
- dev-java/maven-hawtjni-plugin:0"
-
-S="${WORKDIR}/${PN}-${MY_P}"
-JAVA_SRC_DIR="${S}/openssl-dynamic/src/main/java"
-NATIVE_DIR="${S}/openssl-dynamic/src/main/native-package"
-
-java_prepare() {
- cd "${NATIVE_DIR}" || die
- ln -sn ../c src || die
- ln -sn . project-template || die
-
- # Provides missing m4 files and Makefile.am template.
- unzip -n $(java-pkg_getjars --build-only maven-hawtjni-plugin) project-template/\* || die
-
- sed -i \
- -e "s:@PROJECT_NAME@:${PN}:g" \
- -e "s:@PROJECT_NAME_UNDER_SCORE@:${PN//-/_}:g" \
- -e "s:@PROJECT_SOURCES@:$(echo src/*.c):g" \
- Makefile.am || die
-
- # Avoid dummy version and tedious symlink.
- sed -i "s/-release @VERSION@/-avoid-version/g" configure.ac || die
-
- eautoreconf
-}
-
-src_configure(){
- cd "${NATIVE_DIR}" || die
- econf --with-apr=/usr/bin/apr-1-config --with-ssl=/usr
-}
-
-src_compile() {
- java-pkg-simple_src_compile
- emake -C "${NATIVE_DIR}"
-}
-
-src_install() {
- java-pkg-simple_src_install
- java-pkg_doso "${NATIVE_DIR}"/.libs/lib${PN}.so
- dodoc README.md
-}