summaryrefslogtreecommitdiff
path: root/dev-java/netty-buffer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/netty-buffer
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/netty-buffer')
-rw-r--r--dev-java/netty-buffer/Manifest6
-rw-r--r--dev-java/netty-buffer/files/netty-buffer-4.0.21-build.xml229
-rw-r--r--dev-java/netty-buffer/metadata.xml11
-rw-r--r--dev-java/netty-buffer/netty-buffer-4.0.21.ebuild56
-rw-r--r--dev-java/netty-buffer/netty-buffer-4.0.36.ebuild48
5 files changed, 350 insertions, 0 deletions
diff --git a/dev-java/netty-buffer/Manifest b/dev-java/netty-buffer/Manifest
new file mode 100644
index 000000000000..c56bbc1bfb7c
--- /dev/null
+++ b/dev-java/netty-buffer/Manifest
@@ -0,0 +1,6 @@
+AUX netty-buffer-4.0.21-build.xml 9693 BLAKE2B ec0f0c5ba4b4c259e1ab1045124190aa7cf5cc1c33a03acbe75c4f5971c1d39ef0fa99704c9663e56635b12b0f59b5582904ac2b1590f4e85686544a4a9e4472 SHA512 5b082802b6f7c7e619ba053757ede64f0ffa18c3002205207d2d129464aa89f5b52c20133299e280ea937e821a42e525e7885d773f56f0c8000726b56753fbf9
+DIST netty-4.0.21.Final.tar.gz 960489 BLAKE2B ef279fcc2d56baaee62841ad973702c585d5450a45e513ca6beafa295943878b88ed81b8a167091e77aa9f26bccbdcea4138230850dca57321f1241c4ff56d0b SHA512 5d432e9e433c22b82e67ed3463c6982ca95c2ad823165e1ca9a5046e598878f06aac4221be235f2bda15edfdb22028f2a4f74fb37d431f24a2636e4ec60fae74
+DIST netty-4.0.36.Final.tar.gz 1267617 BLAKE2B 351b1f73b1a3c60fd843767254ae57e74d74cdfe570828b1a2e7aea55a203866ae4e232bad285c3937d8f2dc7689534ffb180fcd345c8cf10bced7048ec58ec3 SHA512 b222205963366d5a0f5539c7029dc47edea8d532fca05d169dfe12dbedf956959ba422a22254b09622db428b517da0fd0e58198d11e66193abdb6050481ccbe6
+EBUILD netty-buffer-4.0.21.ebuild 1292 BLAKE2B 7109e2aa22415f7bc730213afedd242873bb98cb54432002cae0d12501393d4e00dde369177d2c6ef75323a4f6cfe11b4b37d6f8a29d57f193ce5188d1b79166 SHA512 51df749a4f546b5bc0e717d6b279397c8c5d1a9045392aea75cd84c89752b49aa0d25003b4cd0742c08980b7c554eec051ff0c78cee3ade65edd15d99e20ec42
+EBUILD netty-buffer-4.0.36.ebuild 1233 BLAKE2B b47b2d96c3b01113edcaffdacbc6a1880d0dc1d7a5151757b2fd39a120f2ba5a60d22adef04503db5a76c42f41234c65a5d24891fb6fa0cee49df66e38c04b4e SHA512 efb521ff910efe81d47ffa700fab5c3031686d00b229906325f532f463fa9039c584a78e823aada5c60951389afb83373e292a3c27db73a6a20ffb13276e90d8
+MISC metadata.xml 322 BLAKE2B bb75fefaf27a5201c39d59fe0baff0538451766c9772cbecaf3ae347774003a2b8fa715f9738ba4324f87ce3a9aece0cb6b7c918660b7cbc6b35909533875ab5 SHA512 70319387d42e91b6b175785761c6dc23500a3c1789ad06d83169c15f8853be4211ae6764ffc5049d5278684271a538c4da9c8dcc8cda9a98e856bf2cee60a65c
diff --git a/dev-java/netty-buffer/files/netty-buffer-4.0.21-build.xml b/dev-java/netty-buffer/files/netty-buffer-4.0.21-build.xml
new file mode 100644
index 000000000000..376c30458ecd
--- /dev/null
+++ b/dev-java/netty-buffer/files/netty-buffer-4.0.21-build.xml
@@ -0,0 +1,229 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 5/15/14 7:12 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="netty-buffer-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="netty-buffer-4.0.21.Final"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ </path>
+ <path id="build.test.classpath">
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="true"
+ debug="true"
+ optimize="true"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="true"
+ memoryInitialSize="1024m"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="true"
+ debug="true"
+ optimize="true"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="true"
+ memoryInitialSize="1024m"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/*Test*.java"/>
+ <include name="**/*Benchmark*.java"/>
+ <exclude name="**/Abstract*"/>
+ <exclude name="**/TestUtil*"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/Abstract*"/>
+ <exclude name="**/TestUtil*"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="false"
+ use="true"
+ author="false"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="true"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+</project>
diff --git a/dev-java/netty-buffer/metadata.xml b/dev-java/netty-buffer/metadata.xml
new file mode 100644
index 000000000000..3a4bd0130d1b
--- /dev/null
+++ b/dev-java/netty-buffer/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">netty/netty</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/netty-buffer/netty-buffer-4.0.21.ebuild b/dev-java/netty-buffer/netty-buffer-4.0.21.ebuild
new file mode 100644
index 000000000000..44d1a7d3625f
--- /dev/null
+++ b/dev-java/netty-buffer/netty-buffer-4.0.21.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="netty"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Async event-driven framework for high performance network applications"
+HOMEPAGE="http://netty.io/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/${MY_P}.Final.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+CDEPEND="dev-java/${MY_PN}-common:0"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}
+ test? (
+ dev-java/ant-core:0
+ dev-java/easymock:3.2
+ dev-java/hamcrest-library:1.3
+ dev-java/junit:4
+ )"
+
+S="${WORKDIR}/${MY_PN}-${MY_P}.Final/${PN/${MY_PN}-}"
+
+EANT_BUILD_TARGET="package"
+EANT_GENTOO_CLASSPATH="${MY_PN}-common"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},ant-core,easymock-3.2,hamcrest-library-1.3,junit-4"
+EANT_TEST_EXTRA_ARGS+=" -Djunit.present=true"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${MY_PN}-*.jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/netty-buffer/netty-buffer-4.0.36.ebuild b/dev-java/netty-buffer/netty-buffer-4.0.36.ebuild
new file mode 100644
index 000000000000..2e4b6c85aa19
--- /dev/null
+++ b/dev-java/netty-buffer/netty-buffer-4.0.36.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="netty"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Async event-driven framework for high performance network applications"
+HOMEPAGE="http://netty.io/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/${MY_P}.Final.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="~dev-java/${MY_PN}-common-${PV}:0"
+
+RDEPEND=">=virtual/jre-1.7
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.7
+ ${CDEPEND}
+ test? (
+ dev-java/easymock:3.2
+ dev-java/hamcrest-core:1.3
+ dev-java/hamcrest-library:1.3
+ dev-java/junit:4
+ )"
+
+S="${WORKDIR}/${MY_PN}-${MY_P}.Final/${PN/${MY_PN}-}"
+JAVA_SRC_DIR="src/main/java"
+JAVA_GENTOO_CLASSPATH="${MY_PN}-common"
+
+src_test() {
+ cd src/test/java || die
+
+ local CP=".:${S}/${PN}.jar:$(java-pkg_getjars --with-dependencies ${JAVA_GENTOO_CLASSPATH},easymock-3.2,hamcrest-core-1.3,hamcrest-library-1.3,junit-4)"
+ local TESTS=$(find * -name "*Test.java" ! -name "Abstract*")
+ TESTS="${TESTS//.java}"
+ TESTS="${TESTS//\//.}"
+
+ ejavac -cp "${CP}" -d . $(find * -name "*.java")
+ ejunit4 -classpath "${CP}" ${TESTS}
+}