summaryrefslogtreecommitdiff
path: root/dev-java/nanoxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/nanoxml
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/nanoxml')
-rw-r--r--dev-java/nanoxml/Manifest5
-rw-r--r--dev-java/nanoxml/files/nanoxml-2.2.3-enum.patch208
-rw-r--r--dev-java/nanoxml/files/nanoxml-2.2.3-lite-enum.patch53
-rw-r--r--dev-java/nanoxml/metadata.xml11
-rw-r--r--dev-java/nanoxml/nanoxml-2.2.3-r4.ebuild45
5 files changed, 322 insertions, 0 deletions
diff --git a/dev-java/nanoxml/Manifest b/dev-java/nanoxml/Manifest
new file mode 100644
index 000000000000..ac86469d24cf
--- /dev/null
+++ b/dev-java/nanoxml/Manifest
@@ -0,0 +1,5 @@
+AUX nanoxml-2.2.3-enum.patch 9487 BLAKE2B 33d1433983f461f50f17a63151b292798036eda70d340ca8d7f139615fc16dda87c6e4d4314952ed8b270a7972ecd06fc1ddda8faa24e505af816c1bf7f0f614 SHA512 cdb5bc356f35e0b1906d2acc6b937ab8102ae34fd688f77e214976417174a3f15c884b1d22715782a19b4c374f9def94d35971ca88b9400c9c28350d3f795769
+AUX nanoxml-2.2.3-lite-enum.patch 2515 BLAKE2B 41f698b9fd685739b181951d1ac022226e5be8e4c4c72078ec4339102f46fb24acd9ba3aa2765f6f9787a9c818bf6c50bc3818835635f48279dc2214a84d284c SHA512 8bb31f737211168bb4a24f2abbd8f4fb78df35bc471116b427b5c2faeb2b1b1710ce5eda793d364a95bd7d7162075f1322dfed4c5a2527c3ae113a8c9a5cb97e
+DIST nanoxml-2.2.3.tar.gz 426111 BLAKE2B ac9980502c8c6ec50c6aebd19c0d08319701a508eea2a58847b804dcb3a3a93ca8d41ee1f08f4ec48527e669fc1695ec945933688516775373458ac7b6564895 SHA512 6800b86039cb555efc05644db65c516fb242d4d081ea612969d6cc52a12ffd7571e012a7afe7962cd61c28b0ebb3b9d94af76f20013f3b4dd7d2aacdc552c6fc
+EBUILD nanoxml-2.2.3-r4.ebuild 875 BLAKE2B 03bff6a5a87cb09ad518fb7d17b95299152af143203c51bf03953261c0a1182168b6900ad94720bc7d6db54e8175cc5aa264f52cbc8e9e41a40ce3ce2392e388 SHA512 2eba557cff7beb1ef4d5d73d75facac6ea5a5980f7432dc60f75bab7b7ac3fe03f2ebc51d5118cdc21dc46732607894a5bd9c6bb167e1dc2c71ea1c29ede82f4
+MISC metadata.xml 313 BLAKE2B f5fa3b22b2233fbfe20819af9612b185c1279d5d6ce3688942d9fd1b651bbf07b92efacd77ad2ca77418dc3c3d384bfe903cc66f65693e79560f3d35e2340da8 SHA512 e9b3806d0286175ade9158968346fd9dc2251dd4f4f7363bfdb147bf08b60f3088d07483971c55b2e1ccf656362d83443cea57a2a6b876a0f1c6107987ee7974
diff --git a/dev-java/nanoxml/files/nanoxml-2.2.3-enum.patch b/dev-java/nanoxml/files/nanoxml-2.2.3-enum.patch
new file mode 100644
index 000000000000..f3992f845b85
--- /dev/null
+++ b/dev-java/nanoxml/files/nanoxml-2.2.3-enum.patch
@@ -0,0 +1,208 @@
+--- a/Sources/Java/net/n3/nanoxml/XMLElement.java.orig 2016-03-04 09:21:07.908000000 +0000
++++ a/Sources/Java/net/n3/nanoxml/XMLElement.java 2016-03-04 09:35:16.283000000 +0000
+@@ -484,9 +484,9 @@
+ * @return the child element, or null if no such child was found.
+ */
+ public IXMLElement getFirstChildNamed(String name) {
+- Enumeration enum = this.children.elements();
+- while (enum.hasMoreElements()) {
+- IXMLElement child = (IXMLElement) enum.nextElement();
++ Enumeration myEnum = this.children.elements();
++ while (myEnum.hasMoreElements()) {
++ IXMLElement child = (IXMLElement) myEnum.nextElement();
+ String childName = child.getFullName();
+ if ((childName != null) && childName.equals(name)) {
+ return child;
+@@ -506,9 +506,9 @@
+ */
+ public IXMLElement getFirstChildNamed(String name,
+ String namespace) {
+- Enumeration enum = this.children.elements();
+- while (enum.hasMoreElements()) {
+- IXMLElement child = (IXMLElement) enum.nextElement();
++ Enumeration myEnum = this.children.elements();
++ while (myEnum.hasMoreElements()) {
++ IXMLElement child = (IXMLElement) myEnum.nextElement();
+ String str = child.getName();
+ boolean found = (str != null) && (str.equals(name));
+ str = child.getNamespace();
+@@ -534,9 +534,9 @@
+ */
+ public Vector getChildrenNamed(String name) {
+ Vector result = new Vector(this.children.size());
+- Enumeration enum = this.children.elements();
+- while (enum.hasMoreElements()) {
+- IXMLElement child = (IXMLElement) enum.nextElement();
++ Enumeration myEnum = this.children.elements();
++ while (myEnum.hasMoreElements()) {
++ IXMLElement child = (IXMLElement) myEnum.nextElement();
+ String childName = child.getFullName();
+ if ((childName != null) && childName.equals(name)) {
+ result.addElement(child);
+@@ -557,9 +557,9 @@
+ public Vector getChildrenNamed(String name,
+ String namespace) {
+ Vector result = new Vector(this.children.size());
+- Enumeration enum = this.children.elements();
+- while (enum.hasMoreElements()) {
+- IXMLElement child = (IXMLElement) enum.nextElement();
++ Enumeration myEnum = this.children.elements();
++ while (myEnum.hasMoreElements()) {
++ IXMLElement child = (IXMLElement) myEnum.nextElement();
+ String str = child.getName();
+ boolean found = (str != null) && (str.equals(name));
+ str = child.getNamespace();
+@@ -585,9 +585,9 @@
+ * @return the attribute, or null if the attribute does not exist.
+ */
+ private XMLAttribute findAttribute(String fullName) {
+- Enumeration enum = this.attributes.elements();
+- while (enum.hasMoreElements()) {
+- XMLAttribute attr = (XMLAttribute) enum.nextElement();
++ Enumeration myEnum = this.attributes.elements();
++ while (myEnum.hasMoreElements()) {
++ XMLAttribute attr = (XMLAttribute) myEnum.nextElement();
+ if (attr.getFullName().equals(fullName)) {
+ return attr;
+ }
+@@ -606,9 +606,9 @@
+ */
+ private XMLAttribute findAttribute(String name,
+ String namespace) {
+- Enumeration enum = this.attributes.elements();
+- while (enum.hasMoreElements()) {
+- XMLAttribute attr = (XMLAttribute) enum.nextElement();
++ Enumeration myEnum = this.attributes.elements();
++ while (myEnum.hasMoreElements()) {
++ XMLAttribute attr = (XMLAttribute) myEnum.nextElement();
+ boolean found = attr.getName().equals(name);
+ if (namespace == null) {
+ found &= (attr.getNamespace() == null);
+@@ -860,9 +860,9 @@
+ */
+ public Enumeration enumerateAttributeNames() {
+ Vector result = new Vector();
+- Enumeration enum = this.attributes.elements();
+- while (enum.hasMoreElements()) {
+- XMLAttribute attr = (XMLAttribute) enum.nextElement();
++ Enumeration myEnum = this.attributes.elements();
++ while (myEnum.hasMoreElements()) {
++ XMLAttribute attr = (XMLAttribute) myEnum.nextElement();
+ result.addElement(attr.getFullName());
+ }
+ return result.elements();
+@@ -897,9 +897,9 @@
+ */
+ public Properties getAttributes() {
+ Properties result = new Properties();
+- Enumeration enum = this.attributes.elements();
+- while (enum.hasMoreElements()) {
+- XMLAttribute attr = (XMLAttribute) enum.nextElement();
++ Enumeration myEnum = this.attributes.elements();
++ while (myEnum.hasMoreElements()) {
++ XMLAttribute attr = (XMLAttribute) myEnum.nextElement();
+ result.put(attr.getFullName(), attr.getValue());
+ }
+ return result;
+@@ -915,9 +915,9 @@
+ */
+ public Properties getAttributesInNamespace(String namespace) {
+ Properties result = new Properties();
+- Enumeration enum = this.attributes.elements();
+- while (enum.hasMoreElements()) {
+- XMLAttribute attr = (XMLAttribute) enum.nextElement();
++ Enumeration myEnum = this.attributes.elements();
++ while (myEnum.hasMoreElements()) {
++ XMLAttribute attr = (XMLAttribute) myEnum.nextElement();
+ if (namespace == null) {
+ if (attr.getNamespace() == null) {
+ result.put(attr.getName(), attr.getValue());
+@@ -1007,9 +1007,9 @@
+ if (this.attributes.size() != elt.getAttributeCount()) {
+ return false;
+ }
+- Enumeration enum = this.attributes.elements();
+- while (enum.hasMoreElements()) {
+- XMLAttribute attr = (XMLAttribute) enum.nextElement();
++ Enumeration myEnum = this.attributes.elements();
++ while (myEnum.hasMoreElements()) {
++ XMLAttribute attr = (XMLAttribute) myEnum.nextElement();
+ if (! elt.hasAttribute(attr.getName(), attr.getNamespace())) {
+ return false;
+ }
+--- a/Sources/Java/net/n3/nanoxml/NonValidator.java.orig 2016-03-04 09:36:05.247000000 +0000
++++ a/Sources/Java/net/n3/nanoxml/NonValidator.java 2016-03-04 09:36:25.195000000 +0000
+@@ -587,10 +587,10 @@
+ int lineNr)
+ {
+ Properties props = (Properties) this.currentElements.pop();
+- Enumeration enum = props.keys();
++ Enumeration myEnum = props.keys();
+
+- while (enum.hasMoreElements()) {
+- String key = (String) enum.nextElement();
++ while (myEnum.hasMoreElements()) {
++ String key = (String) myEnum.nextElement();
+ extraAttributes.put(key, props.get(key));
+ }
+ }
+--- a/Sources/Java/net/n3/nanoxml/XMLWriter.java.orig 2016-03-04 09:36:53.616000000 +0000
++++ a/Sources/Java/net/n3/nanoxml/XMLWriter.java 2016-03-04 09:38:11.868000000 +0000
+@@ -182,10 +182,10 @@
+ }
+ }
+
+- Enumeration enum = xml.enumerateAttributeNames();
++ Enumeration myEnum = xml.enumerateAttributeNames();
+
+- while (enum.hasMoreElements()) {
+- String key = (String) enum.nextElement();
++ while (myEnum.hasMoreElements()) {
++ String key = (String) myEnum.nextElement();
+ int index = key.indexOf(':');
+
+ if (index >= 0) {
+@@ -203,10 +203,10 @@
+ }
+ }
+
+- enum = xml.enumerateAttributeNames();
++ myEnum = xml.enumerateAttributeNames();
+
+- while (enum.hasMoreElements()) {
+- String key = (String) enum.nextElement();
++ while (myEnum.hasMoreElements()) {
++ String key = (String) myEnum.nextElement();
+ String value = xml.getAttribute(key, null);
+ this.writer.print(" " + key + "=\"");
+ this.writeEncoded(value);
+@@ -229,10 +229,10 @@
+ writer.println();
+ }
+
+- enum = xml.enumerateChildren();
++ myEnum = xml.enumerateChildren();
+
+- while (enum.hasMoreElements()) {
+- IXMLElement child = (IXMLElement) enum.nextElement();
++ while (myEnum.hasMoreElements()) {
++ IXMLElement child = (IXMLElement) myEnum.nextElement();
+ this.write(child, prettyPrint, indent + 4,
+ collapseEmptyElements);
+ }
+--- a/Sources/Java/net/n3/nanoxml/StdXMLParser.java.orig 2016-03-04 09:38:44.521000000 +0000
++++ a/Sources/Java/net/n3/nanoxml/StdXMLParser.java 2016-03-04 09:39:08.028000000 +0000
+@@ -492,10 +492,10 @@
+ extraAttributes,
+ this.reader.getSystemID(),
+ this.reader.getLineNr());
+- Enumeration enum = extraAttributes.keys();
++ Enumeration myEnum = extraAttributes.keys();
+
+- while (enum.hasMoreElements()) {
+- String key = (String) enum.nextElement();
++ while (myEnum.hasMoreElements()) {
++ String key = (String) myEnum.nextElement();
+ String value = extraAttributes.getProperty(key);
+ attrNames.addElement(key);
+ attrValues.addElement(value);
diff --git a/dev-java/nanoxml/files/nanoxml-2.2.3-lite-enum.patch b/dev-java/nanoxml/files/nanoxml-2.2.3-lite-enum.patch
new file mode 100644
index 000000000000..602cd9f87909
--- /dev/null
+++ b/dev-java/nanoxml/files/nanoxml-2.2.3-lite-enum.patch
@@ -0,0 +1,53 @@
+--- a/Sources/Lite/nanoxml/XMLElement.java.orig 2016-03-04 09:16:52.339000000 +0000
++++ a/Sources/Lite/nanoxml/XMLElement.java 2016-03-04 09:19:03.213000000 +0000
+@@ -63,8 +63,8 @@
+ * The following example shows how to list the attributes of an element:
+ * <UL><CODE>
+ * XMLElement element = ...;<BR>
+- * Enumeration enum = element.getAttributeNames();<BR>
+- * while (enum.hasMoreElements()) {<BR>
++ * Enumeration myEnum = element.getAttributeNames();<BR>
++ * while (myEnum.hasMoreElements()) {<BR>
+ * &nbsp;&nbsp;&nbsp;&nbsp;String key = (String) enum.nextElement();<BR>
+ * &nbsp;&nbsp;&nbsp;&nbsp;String value = element.getStringAttribute(key);<BR>
+ * &nbsp;&nbsp;&nbsp;&nbsp;System.out.println(key + " = " + value);<BR>
+@@ -478,9 +478,9 @@
+ this.children = new Vector();
+ this.entities = entities;
+ this.lineNr = 0;
+- Enumeration enum = this.entities.keys();
+- while (enum.hasMoreElements()) {
+- Object key = enum.nextElement();
++ Enumeration myEnum = this.entities.keys();
++ while (myEnum.hasMoreElements()) {
++ Object key = myEnum.nextElement();
+ Object value = this.entities.get(key);
+ if (value instanceof String) {
+ value = ((String) value).toCharArray();
+@@ -2168,10 +2168,10 @@
+ writer.write('<');
+ writer.write(this.name);
+ if (! this.attributes.isEmpty()) {
+- Enumeration enum = this.attributes.keys();
+- while (enum.hasMoreElements()) {
++ Enumeration myEnum = this.attributes.keys();
++ while (myEnum.hasMoreElements()) {
+ writer.write(' ');
+- String key = (String) enum.nextElement();
++ String key = (String) myEnum.nextElement();
+ String value = (String) this.attributes.get(key);
+ writer.write(key);
+ writer.write('='); writer.write('"');
+@@ -2189,9 +2189,9 @@
+ writer.write('/'); writer.write('>');
+ } else {
+ writer.write('>');
+- Enumeration enum = this.enumerateChildren();
+- while (enum.hasMoreElements()) {
+- XMLElement child = (XMLElement) enum.nextElement();
++ Enumeration myEnum = this.enumerateChildren();
++ while (myEnum.hasMoreElements()) {
++ XMLElement child = (XMLElement) myEnum.nextElement();
+ child.write(writer);
+ }
+ writer.write('<'); writer.write('/');
diff --git a/dev-java/nanoxml/metadata.xml b/dev-java/nanoxml/metadata.xml
new file mode 100644
index 000000000000..4c006a5b2b06
--- /dev/null
+++ b/dev-java/nanoxml/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">nanoxml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/nanoxml/nanoxml-2.2.3-r4.ebuild b/dev-java/nanoxml/nanoxml-2.2.3-r4.ebuild
new file mode 100644
index 000000000000..023a196112c0
--- /dev/null
+++ b/dev-java/nanoxml/nanoxml-2.2.3-r4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+MY_P="NanoXML-${PV}"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="NanoXML is a small non-validating parser for Java"
+HOMEPAGE="http://nanoxml.sourceforge.net/"
+SRC_URI="http://pkgs.fedoraproject.org/repo/pkgs/nanoxml/${MY_P}.tar.gz/357c7136417ea996cf714278ea84f2df/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+CDEPEND="dev-java/sax:0"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+S="${WORKDIR}/${MY_P}"
+
+JAVA_GENTOO_CLASSPATH="sax"
+
+JAVA_SRC_DIR="Sources"
+
+PATCHES=(
+ "${FILESDIR}"/"${P}-lite-enum.patch"
+ "${FILESDIR}"/"${P}-enum.patch"
+)
+
+src_prepare() {
+ default
+ java-pkg_clean
+ rm -rf Test || die
+}