summaryrefslogtreecommitdiff
path: root/dev-java/mimepull
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/mimepull
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/mimepull')
-rw-r--r--dev-java/mimepull/Manifest6
-rw-r--r--dev-java/mimepull/files/mimepull-maven-build.xml231
-rw-r--r--dev-java/mimepull/metadata.xml14
-rw-r--r--dev-java/mimepull/mimepull-1.8.ebuild44
-rw-r--r--dev-java/mimepull/mimepull-1.9.6-r1.ebuild23
5 files changed, 318 insertions, 0 deletions
diff --git a/dev-java/mimepull/Manifest b/dev-java/mimepull/Manifest
new file mode 100644
index 000000000000..fd7d8aa88805
--- /dev/null
+++ b/dev-java/mimepull/Manifest
@@ -0,0 +1,6 @@
+AUX mimepull-maven-build.xml 9697 BLAKE2B a297e74be1aa6bddf7c15b8601df79246a41d8490677bc555fee4db1a1ee81cfeb48ec5226f071c7869638fd8284309ee8857b4c9909a78fa922c5860bef01a5 SHA512 23ec5dfc06aa518632e9d69ddc6633010f0a41baa73f7a9e8695b8666927a2612b9ba3b31a74e9fae436dabb51657e39f2623acb41da14b3df71a93eb64dfa9e
+DIST mimepull-1.8.tar.bz2 48841 BLAKE2B ebc5ba45cff2d01c3d0960433f3334cd9c2e39bf9a627b41b3682ece4e376fc10ad53b00773cbb91fb66463e0f9d29790eb4f55dbd27c4b29b70a6fc24856c0d SHA512 60de5b888ccdf89ffdeba0a5ccd98e77f7497e57c6b3c71049446dab0293836f8f2b84a39354602e9073fb6fef880dbc11c80323413f8ed15f0a3af68086ae07
+DIST mimepull-1.9.6.jar 68382 BLAKE2B a59c4837dd82fa2a1e67e653870ead62c6db6ede03690eb483724d2a9bdb588e34145eff604b372a417cda12a1f4074741630e47b3acd81f438145c938d04578 SHA512 528eb77d6edbbfb1b1d8aebb617f9d20c84b9c18f7ab763163ea136c3898319519bbfa8a8e204bd0697a4eac9b964eaf3fb2ee214555efcb3da152ebf467ae64
+EBUILD mimepull-1.8.ebuild 953 BLAKE2B 1ffe4e9a41b81eae44414e20c84ea4c570c7f9786bdce7ffa33a81ad92e0a1e66da84f2477706603a0c849eb39504d62719ac5aa125c5d8d90229bcc7707c624 SHA512 ad20b2a6b8abc3d49028f575efe82b69218ba156411fbcbac7400934169d5d41dc54649fba4c35fdc575aa5032f8546da941f15dd0ce8f079e5f7d6998c8469f
+EBUILD mimepull-1.9.6-r1.ebuild 496 BLAKE2B 51f4d6ae0fc26652cc9adb3ecd26e0d72f019ab6d2660b30e368071c7a935a61434fbcaf96274836b05646f2fbd057d68814ed115857e6a601cb20768897d408 SHA512 97fe69a0ce8b215a306347a17655fd156754150a22593262927b0dee1740044239c433478fc6bb44bca14ddb9f2b60872b32cfce81acf65550e8d95faeeda357
+MISC metadata.xml 573 BLAKE2B f056f34e757829704b8efe77f55e2da69d27a7dc086cde47135854469195578f1b9dd3b67638a0379bc30eff764c25269a93560e11e0e12f9d7440308d240f44 SHA512 5ba96c89a6e2e5c29367ec1b5e52ab3abbfa7bdb0d8e1dd2e305980d83de83b4c29d657e5ecb4a9c1eb3804fd8589b5de86e4f34f70b951b14b2ed453a8ef427
diff --git a/dev-java/mimepull/files/mimepull-maven-build.xml b/dev-java/mimepull/files/mimepull-maven-build.xml
new file mode 100644
index 000000000000..af6d5ea93733
--- /dev/null
+++ b/dev-java/mimepull/files/mimepull-maven-build.xml
@@ -0,0 +1,231 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 5/31/12 11:02 AM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="mimepull-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property name="maven.build.finalName" value="mimepull"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ </target>
+
+</project>
diff --git a/dev-java/mimepull/metadata.xml b/dev-java/mimepull/metadata.xml
new file mode 100644
index 000000000000..b06e421248fc
--- /dev/null
+++ b/dev-java/mimepull/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <longdescription lang="en">
+ This provides a streaming API to access attachments parts in a MIME message.
+ Often times, a large MIME message cannot be loaded into memory. Hence the
+ whole message or attachment parts are written to a file system and access to
+ the attachment parts is provided using those files.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-java/mimepull/mimepull-1.8.ebuild b/dev-java/mimepull/mimepull-1.8.ebuild
new file mode 100644
index 000000000000..61e403db28c5
--- /dev/null
+++ b/dev-java/mimepull/mimepull-1.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Pull API for parsing MIME messages"
+HOMEPAGE="http://java.net/projects/mimepull"
+# svn export https://svn.java.net/svn/mimepull~svn/tags/mimepull-1.8 mimepull-1.8
+# tar cjf mimepull-1.8.tar.bz2 mimepull-1.8
+SRC_URI="https://dev.gentoo.org/~sera/distfiles/${P}.tar.bz2"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.5"
+DEPEND="
+ >=virtual/jdk-1.5
+ test? ( dev-java/ant-junit:0 )"
+
+java_prepare() {
+ find -name '*.class' -exec rm -v {} + || die
+
+ cp "${FILESDIR}"/${PN}-maven-build.xml build.xml || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/mimepull/mimepull-1.9.6-r1.ebuild b/dev-java/mimepull/mimepull-1.9.6-r1.ebuild
new file mode 100644
index 000000000000..301cfe14b421
--- /dev/null
+++ b/dev-java/mimepull/mimepull-1.9.6-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="source doc"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Pull API for parsing MIME messages"
+HOMEPAGE="http://java.net/projects/mimepull"
+SRC_URI="https://repo1.maven.org/maven2/org/jvnet/${PN}/${PN}/${PV}/${P}-sources.jar -> ${P}.jar"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=virtual/jdk-1.7"
+
+RDEPEND="
+ >=virtual/jre-1.7"