summaryrefslogtreecommitdiff
path: root/dev-java/mill-bin/mill-bin-0.11.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-07 13:06:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-07 13:06:42 +0000
commit1b97f0352e38f8346984329b82a8be71632220a6 (patch)
treea2eedd48c9161522b87c70d55cbb7d28d2cb36a9 /dev-java/mill-bin/mill-bin-0.11.7.ebuild
parenta03bc69159ecc073f051ca2079848553a8e34664 (diff)
gentoo auto-resync : 07:03:2024 - 13:06:41
Diffstat (limited to 'dev-java/mill-bin/mill-bin-0.11.7.ebuild')
-rw-r--r--dev-java/mill-bin/mill-bin-0.11.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-java/mill-bin/mill-bin-0.11.7.ebuild b/dev-java/mill-bin/mill-bin-0.11.7.ebuild
new file mode 100644
index 000000000000..5b24c097e25e
--- /dev/null
+++ b/dev-java/mill-bin/mill-bin-0.11.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN%-bin}
+
+DESCRIPTION="A Java/Scala build tool"
+HOMEPAGE="https://com-lihaoyi.github.io/mill/"
+SRC_URI="https://github.com/com-lihaoyi/${MY_PN}/releases/download/${PV}/${PV}-assembly -> ${P}"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ newbin "${DISTDIR}"/${P} ${MY_PN}
+}