summaryrefslogtreecommitdiff
path: root/dev-java/maven-hawtjni-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/maven-hawtjni-plugin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/maven-hawtjni-plugin')
-rw-r--r--dev-java/maven-hawtjni-plugin/Manifest3
-rw-r--r--dev-java/maven-hawtjni-plugin/maven-hawtjni-plugin-1.11.ebuild29
-rw-r--r--dev-java/maven-hawtjni-plugin/metadata.xml11
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-java/maven-hawtjni-plugin/Manifest b/dev-java/maven-hawtjni-plugin/Manifest
new file mode 100644
index 000000000000..ae5f46e7a005
--- /dev/null
+++ b/dev-java/maven-hawtjni-plugin/Manifest
@@ -0,0 +1,3 @@
+DIST hawtjni-project-1.11.tar.gz 1603735 BLAKE2B 1ef2986ce40e6cadf7256699e1b1527a39e85672f02602855804e1bbf9b7d915bd683abef5f30b99ed7edc56eef4cafaa6e75698fa45b0b64491ef8309d51387 SHA512 0fafe29dd058eee07e9c26179b7605cc092254199ccb913064002c882e7ab55ecc4045dd2baab99bbc46d6bf28a9f4f2108c210616e3a9c4a92582c65e6de4e4
+EBUILD maven-hawtjni-plugin-1.11.ebuild 672 BLAKE2B 5d2e7c6db61b8a414d1bda5c0c718f4de949640dd5bf947d4874fac764c45b3b9bee269fd878bfcd3f3a16a26163994e9c0681fd745356cf7fa68def99043ab1 SHA512 6eef7c1cefa80c1eb7411c8c0d799e5d9562598bf3f84f32d4cdba102df0a016581dc76f863181784fd49b75bc6ad0f4d4712273c5145b60c7b73941165e7c7b
+MISC metadata.xml 319 BLAKE2B a8ff6beec59dcc3e34b41cc80d269095ece235e2254d412e2c7b2493f9d2804d273b52f9c550ad7ab9e37f512edb293db91d5ecfc2520c1637f9f610eddf80a0 SHA512 898070ae9d50aff49b3a7273149ee1cf57fb770acb71dbe57c40bc53a10ff5b07d1a461c7a88d361ddcbf15863c228db494092119d84c1b8b0439b9e5dfb2e74
diff --git a/dev-java/maven-hawtjni-plugin/maven-hawtjni-plugin-1.11.ebuild b/dev-java/maven-hawtjni-plugin/maven-hawtjni-plugin-1.11.ebuild
new file mode 100644
index 000000000000..29f28f1b6d3a
--- /dev/null
+++ b/dev-java/maven-hawtjni-plugin/maven-hawtjni-plugin-1.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit java-pkg-2
+
+MY_P="hawtjni-project-${PV}"
+
+DESCRIPTION="Maven plugin for the HawtJNI code generator (resources only)"
+HOMEPAGE="https://github.com/fusesource/hawtjni"
+SRC_URI="https://github.com/fusesource/hawtjni/archive/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.7"
+RDEPEND=">=virtual/jre-1.7"
+
+S="${WORKDIR}/hawtjni-${MY_P}/${PN}"
+
+src_compile() {
+ touch ${PN}.jar || die # jar won't create on update.
+ java-pkg_addres ${PN}.jar src/main/resources
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+}
diff --git a/dev-java/maven-hawtjni-plugin/metadata.xml b/dev-java/maven-hawtjni-plugin/metadata.xml
new file mode 100644
index 000000000000..6208a5add14c
--- /dev/null
+++ b/dev-java/maven-hawtjni-plugin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fusesource/hawtjni</remote-id>
+ </upstream>
+</pkgmetadata>