summaryrefslogtreecommitdiff
path: root/dev-java/lzma/lzma-19.00.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-java/lzma/lzma-19.00.ebuild
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-java/lzma/lzma-19.00.ebuild')
-rw-r--r--dev-java/lzma/lzma-19.00.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-java/lzma/lzma-19.00.ebuild b/dev-java/lzma/lzma-19.00.ebuild
new file mode 100644
index 000000000000..88e381330a05
--- /dev/null
+++ b/dev-java/lzma/lzma-19.00.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java code for LZMA compression and decompression"
+HOMEPAGE="https://www.7-zip.org/"
+SRC_URI="https://www.7-zip.org/a/${PN}${PV/./}.7z"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND=">=virtual/jdk-1.8:*"
+BDEPEND="app-arch/p7zip"
+
+S="${WORKDIR}/Java"
+
+JAVA_SRC_DIR="SevenZip"