summaryrefslogtreecommitdiff
path: root/dev-java/jython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-java/jython
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-java/jython')
-rw-r--r--dev-java/jython/Manifest1
-rw-r--r--dev-java/jython/jython-2.7.0-r3.ebuild152
2 files changed, 153 insertions, 0 deletions
diff --git a/dev-java/jython/Manifest b/dev-java/jython/Manifest
index b1211290ee0a..7e1af474a680 100644
--- a/dev-java/jython/Manifest
+++ b/dev-java/jython/Manifest
@@ -7,4 +7,5 @@ AUX jython-2.7_beta1-dont-always-recompile-classes.patch 309 BLAKE2B 72fe6e0afe6
AUX jython-2.7_beta2-maxrepeat-import.patch 457 BLAKE2B a55f47a16264544608ba9916d3f2ced081a4f47d260bab2eeeb5959ad1aaf1074a69bea4d8083383d039f541f6b379a141c81c4376a7f7cf324ce06ddeb84ab1 SHA512 e06ddb36805e2545f351d9d5df651fa90b0b39d340e4772cbb24910f1e1c999463a21fbe4a62c9cc73f9ccdc0047f8900e6300602cb8d5b70cef7cacf1bd46d0
DIST jython-2.7.0-sources.jar 15371691 BLAKE2B 7e1c29f2a2c03b034e89bb9c3a8fdddbaef6a0191a7320c82b76e31b41336f3d99c1995b2e9864c033ec53629d45669ad460fb4a1433ea7bc6b0390919500a24 SHA512 7583810245d694fd1d99a57ad504fcefdfbc1183def2cbb93ae3660f341104205c73041d846bdcf2b564b3cf4b770b481703c1dcdb1458396812c92d30ee9fa6
EBUILD jython-2.7.0-r2.ebuild 4293 BLAKE2B bda7d9292683c1b8d1b411e537cd82820a4cea8ecc53ac43089bb8252cdfee7f5c89a9cbaac05970a547c0aa27a35739237d7026cb347156baf27f74fae1fad5 SHA512 65412b5ecbf72f2dc4e8f7873e600e3fb044b8377c07b9b1e3ace713796603945b0c823d8064eceb0700434045693926ea5ddc8ec6ab758683b42f9b37064576
+EBUILD jython-2.7.0-r3.ebuild 4288 BLAKE2B ff21369c1d36b3db3a5a4b87a14c7112778769b6bd3efc55bd3d79feacd71e112099d4e2912db49b2259e4c9e95b66bec7bd990ac5809bec8e5c3fd9cc2960ca SHA512 74ca760a0f631dfcada8574a6d4a5f50b683e8aec53868599844109d8ea02c08e3e7753aa5a9e55481f23599b9f251138dfdf10abca93d3cea0342b54368c25d
MISC metadata.xml 323 BLAKE2B 4c2b07b6a519fb3f1e4f7d0662e2488705d8ba2239a6cbd25b42aebd1bff1ca368105e1c5eee604915428c5b909ecc2547f6be4dfad126139a7f496bb276ae02 SHA512 de33eb0b1518ca8c0c9f8a44880946f491620bbcbfe0d5ebcb68dca71eba3965f0cf0ccd8c67128022c33845699222bd8b899c061cb5f7d7c0e09a4783fa3464
diff --git a/dev-java/jython/jython-2.7.0-r3.ebuild b/dev-java/jython/jython-2.7.0-r3.ebuild
new file mode 100644
index 000000000000..e4c5606e1118
--- /dev/null
+++ b/dev-java/jython/jython-2.7.0-r3.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2 python-utils-r1 flag-o-matic
+
+MY_PV=${PV/_beta/-b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="An implementation of Python written in Java"
+HOMEPAGE="https://www.jython.org"
+SRC_URI="https://search.maven.org/remotecontent?filepath=org/python/${PN}/${MY_PV}/${MY_P}-sources.jar"
+
+LICENSE="PSF-2"
+SLOT="2.7"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+CP_DEPEND="dev-java/antlr:3
+ dev-java/netty-transport:0
+ dev-java/asm:9
+ dev-java/commons-compress:0
+ dev-java/guava:20
+ dev-java/jffi:1.2
+ dev-java/jline:2
+ dev-java/icu4j:55
+ dev-java/jnr-constants:0
+ dev-java/jnr-posix:3.0
+ dev-java/jnr-netdb:1.0
+ dev-java/stringtemplate:0
+ dev-java/xerces:2
+ java-virtuals/script-api:0
+ java-virtuals/servlet-api:3.0"
+RDEPEND="${CP_DEPEND}
+ >=virtual/jre-1.8:*"
+DEPEND="${CP_DEPEND}
+ >=virtual/jdk-1.8:*
+ dev-java/ant-core:0
+ test? (
+ dev-java/junit:4
+ dev-java/ant-junit:0
+ )"
+BDEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+RESTRICT="test"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+JAVA_ANT_CLASSPATH_TAGS+=" java"
+
+EANT_BUILD_TARGET="developer-build"
+EANT_TEST_EXTRA_ARGS="-Dpython.home=dist"
+
+# jdbc-informix and jdbc-oracle-bin (requires registration) aren't exposed.
+# Uncomment and add to CDEPEND if you want either of them
+#EANT_GENTOO_CLASSPATH+=",jdbc-informix" EANT_EXTRA_ARGS+=" -Dinformix.present"
+#EANT_GENTOO_CLASSPATH+=",jdbc-oracle-bin" EANT_EXTRA_ARGS+=" -Doracle.present"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.2-distutils_scripts_location.patch
+ "${FILESDIR}"/${PN}-2.5.2-respect_PYTHONPATH.patch
+ "${FILESDIR}"/${PN}-2.7_beta1-ant.patch
+ "${FILESDIR}"/${PN}-2.7_beta1-dont-always-recompile-classes.patch
+ "${FILESDIR}"/${PN}-2.7_beta2-maxrepeat-import.patch
+ "${FILESDIR}"/${PN}-2.7.0-build.xml.patch
+ "${FILESDIR}"/CVE-2016-4000.patch
+)
+
+src_prepare() {
+ default
+
+ find \( -name '*.jar' -o -name '*.class' \
+ -o -name '*.pyc' -o -name '*.exe' \) -delete
+
+ # needed for launchertest
+ chmod +x tests/shell/test-jython.sh || die
+
+ java-pkg-2_src_prepare
+}
+
+src_configure() {
+ # apparently this can cause problems
+ append-flags -fno-stack-protector
+
+ EANT_GENTOO_CLASSPATH_EXTRA="$(java-pkg_getjars --with-dependencies antlr-3,jnr-posix-3.0)"
+ EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjars --build-only ant-core)"
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ local instdir=/usr/share/${PN}-${SLOT}
+
+ java-pkg_newjar dist/${PN}-dev.jar
+
+ java-pkg_register-optional-dependency jdbc-mysql
+ java-pkg_register-optional-dependency jdbc-postgresql
+
+ insinto ${instdir}
+ doins -r dist/{Lib,registry}
+
+ dodoc ACKNOWLEDGMENTS NEWS README.txt
+
+ use doc && java-pkg_dohtml -r dist/Doc/javadoc
+ use source && java-pkg_dosrc src/*
+ use examples && java-pkg_doexamples Demo/*
+
+ local java_args=(
+ -Dpython.home="${EPREFIX}"/usr/share/${PN}-${SLOT}
+ -Dpython.executable="${EPREFIX}"/usr/bin/jython${SLOT}
+ -Dpython.cachedir="\${HOME}/.jythoncachedir"
+ )
+
+ java-pkg_dolauncher jython${SLOT} \
+ --main org.python.util.jython \
+ --java_args "${java_args[*]}"
+
+ # we need a wrapper to help python_optimize
+ cat <<-EOF > "${T}"/jython
+ exec java -cp "$(java-pkg_getjars "${EANT_GENTOO_CLASSPATH}"):${EANT_GENTOO_CLASSPATH_EXTRA}:dist/${PN}-dev.jar" \
+ -Dpython.home="${ED}${instdir}" \
+ -Dpython.cachedir="${T}/.jythoncachedir" \
+ -Duser.home="${T}" \
+ org.python.util.jython "\${@}"
+ EOF
+ chmod +x "${T}"/jython || die
+
+ local -x PYTHON="${T}"/jython
+ # we can't get the path from the interpreter since it does some
+ # magic that fails on non-installed copy...
+ _python_export jython${SLOT} EPYTHON
+
+ # compile tests (everything else is compiled already)
+ # we're keeping it quiet since jython reports errors verbosely
+ # and some of the tests are supposed to trigger compile errors
+ python_optimize "${ED}${instdir}"/Lib/test &>/dev/null
+
+ # for python-exec
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
+ python_moduleinto "/usr/share/jython-${SLOT}/Lib/site-packages"
+ python_domodule epython.py
+
+ # some of the class files end up with newer timestamps than the files they
+ # were generated from, make sure this doesn't happen
+ find "${ED}${instdir}"/Lib/ -name '*.class' | xargs touch
+}