summaryrefslogtreecommitdiff
path: root/dev-java/junit-addons
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-java/junit-addons
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/junit-addons')
-rw-r--r--dev-java/junit-addons/Manifest5
-rw-r--r--dev-java/junit-addons/files/1.4-build.xml230
-rw-r--r--dev-java/junit-addons/files/1.4-common.properties15
-rw-r--r--dev-java/junit-addons/junit-addons-1.4-r1.ebuild67
-rw-r--r--dev-java/junit-addons/metadata.xml15
5 files changed, 0 insertions, 332 deletions
diff --git a/dev-java/junit-addons/Manifest b/dev-java/junit-addons/Manifest
deleted file mode 100644
index 37e3434c3c26..000000000000
--- a/dev-java/junit-addons/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX 1.4-build.xml 8725 BLAKE2B bdc668244b90693cd60f294d188b200b51929093c988ce96bda06231ae0df781515de678115cb6f8810aeda1f6c380f0405350bd9dc6e8804fb1240042d5c311 SHA512 3f3eae33867f9e311e8e2e58a87dbc67dc4beb6eb89793b2b477953a1fc5cba45aad2a8241e07717de472969ec448c6205617da2427243cfdb21f0cf4ba91b12
-AUX 1.4-common.properties 540 BLAKE2B 48c40f53f6f5557f5b97753209782ef3c57c53817ad2e7e04de7cc234ce84cf1abc9b7bdeefad992d3ea0586fb8aa72fe37942d63833cc3ceba01b400f23b432 SHA512 9362f56305b2d6cd97a10ed6cd661de6ae86e700d250cf69c55f922fca2c6f57e8ce1c306ad4378196c18cc8b839bcd5440816f6ef60f908a28da7b4ef78bbc6
-DIST junit-addons-1.4.zip 293750 BLAKE2B f305ae548ee9577ff9c5be01846768fe111a2cc7c523a080f5bfe823f6e2def5880fce091cd3e460eeae831e639616ec7cbf203dcee1dce66a7075a6343df1df SHA512 0ddc9a95d80190417c92e86697669020a2947e2211d2394334b80d76bca5397f132d90e00d0c679bf48607fbadf8d1d6e97d3770d06c35cab78c6cada198434a
-EBUILD junit-addons-1.4-r1.ebuild 1458 BLAKE2B 6c82788d394202095b5356e189603e27e57a43336e459b2f81c3fdb09d7363ef226fa6967709b4765dc1c8f930a1ce77a4a8b684d34b045814430c6bfeb5c469 SHA512 9b429406c445445282184cda4f61ee0cf8c43d3a7a7bd0fc27e0e59628e53121c752e659850e79aa07bd0f7fe426477a7c1a9f0e72cca341e77732e05d75ec57
-MISC metadata.xml 490 BLAKE2B 01319745e5907693e1cc616f05f66b4e049258cfe26a585af35a4ba5e56c7d78a338b374ff42558ce05c7523da5d330084b274aa91967f8a6ad4a06adab4e564 SHA512 bfa7b8058d0f28bd1455f2ab6841b562f369a62d90bd6a1a875c67c991dc75ade65c6e854351a4dee83d2ae059185e82a84f3159095a174aa48fdbfa8070b3fa
diff --git a/dev-java/junit-addons/files/1.4-build.xml b/dev-java/junit-addons/files/1.4-build.xml
deleted file mode 100644
index 5b171e1051ab..000000000000
--- a/dev-java/junit-addons/files/1.4-build.xml
+++ /dev/null
@@ -1,230 +0,0 @@
-<?xml version="1.0" encoding="ISO-8859-1"?>
-
-<!--
- - Build file for the JUnit-addons Project.
- -
- - This script should be started with the following command line :
- -
- - ant <target>
- -
- - Run "ant -projecthelp" to get a list of available targets.
- -
- - Take from upstream CVS and modified a little for Gentoo:
- - Version: Revision: 1.15 Date: 2003/04/09 04:41:10
- - Author: Vladimir R. Bossicard (vbossica@users.sourceforge.net)
- -->
-
-<project name="junit-addons" default="build" basedir=".">
-
- <property file="build.properties" />
- <property file="common.properties" />
-
- <!-- directories settings -->
-
- <property name="src" value="src" />
- <property name="main.src" value="src/main" />
- <property name="test.src" value="src/test" />
- <property name="example.src" value="src/example" />
-
- <property name="build.dest" value="build" />
- <property name="api.dest" value="${build.dest}/api" />
- <property name="classes.dest" value="${build.dest}/classes" />
- <property name="test.classes.dest" value="${build.dest}/classes-test" />
- <property name="example.classes.dest" value="${build.dest}/classes-example" />
- <property name="dist.dest" value="dist" />
-
- <!-- miscellaneous settings -->
-
- <property name="compilation.debug" value="on" />
- <property name="compilation.deprecation" value="off" />
- <property name="compilation.verbose" value="off" />
-
- <!--
- - Initializes the build and check if all libraries are available.
- -->
- <target name="init">
- <tstamp/>
- <mkdir dir="${build.dest}" />
- <mkdir dir="${classes.dest}" />
- <mkdir dir="${test.classes.dest}" />
- <mkdir dir="${example.classes.dest}" />
- <mkdir dir="${api.dest}" />
- <mkdir dir="${dist.dest}" />
- </target>
-
- <path id="libraries">
- <pathelement location="${jdom.jar}" />
- <pathelement location="${jaxen.jar}" />
- <pathelement location="${saxpath.jar}" />
- <pathelement location="${ant.jar}" />
- <pathelement location="${junit.jar}" />
- <pathelement location="${xerces.jar}" />
- <pathelement location="${xml-apis.jar}" />
- <pathelement location="${commons-logging.jar}" />
- </path>
-
- <!--
- - Compiles the source code to the build dir
- - Copy all other resources to the build dir
- - which are needed to run the application alone
- -->
- <target name="build"
- depends="init"
- description="compiles the junit-addons classes">
- <javac srcdir="${main.src}"
- destdir="${classes.dest}"
- debug="${compilation.debug}"
- verbose="${compilation.verbose}"
- deprecation="${compilation.deprecation}">
- <classpath>
- <path refid="libraries"/>
- </classpath>
- </javac>
-
- <javac srcdir="${example.src}"
- destdir="${example.classes.dest}"
- debug="${compilation.debug}"
- verbose="${compilation.verbose}"
- deprecation="${compilation.deprecation}">
- <classpath>
- <pathelement location="${classes.dest}" />
- <path refid="libraries"/>
- </classpath>
- </javac>
-
- <javac srcdir="${test.src}"
- destdir="${test.classes.dest}"
- debug="${compilation.debug}"
- verbose="${compilation.verbose}"
- deprecation="${compilation.deprecation}">
- <classpath>
- <pathelement location="${classes.dest}" />
- <pathelement location="${example.classes.dest}" />
- <path refid="libraries"/>
- </classpath>
- </javac>
- </target>
-
- <target name="test"
- depends="build"
- description="tests the junit-addons classes">
- <java classname="junitx.runner.TestRunner" fork="yes">
- <jvmarg value="-DPropertyManager.file=${test.src}/tests.properties" />
- <jvmarg value="-DXMLPropertyManager.file=${test.src}/tests.xml" />
- <arg line="-verbose" />
- <arg line="-runner.properties /home/vladimir/projects/junit-addons-runner/src/main/conf/runner.properties" />
- <arg line="-test.properties ${test.src}/tests.properties" />
- <arg line="-class AllTests" />
- <classpath>
- <pathelement location="${classes.dest}" />
- <pathelement location="${test.classes.dest}" />
- <pathelement location="${example.classes.dest}" />
- <pathelement location="${example.src}" />
- <pathelement location="${junit-addons-runner.jar}" />
- <path refid="libraries"/>
- </classpath>
- </java>
- </target>
-
- <target name="test-old"
- depends="build">
- <java classname="junit.textui.TestRunner" fork="yes">
- <arg line="-class AllTests" />
- <jvmarg value="-DPropertyManager.file=${test.src}/tests.properties" />
- <jvmarg value="-DXMLPropertyManager.file=${test.src}/tests.xml" />
- <classpath>
- <pathelement location="${classes.dest}" />
- <pathelement location="${test.classes.dest}" />
- <pathelement location="${example.classes.dest}" />
- <pathelement location="${example.src}" />
- <path refid="libraries"/>
- </classpath>
- </java>
- </target>
-
- <target name="example"
- depends="build"
- description="compiles and runs the examples">
- <javac srcdir="${example.src}"
- destdir="${test.classes.dest}"
- debug="${compilation.debug}"
- verbose="${compilation.verbose}"
- deprecation="${compilation.deprecation}">
- <classpath>
- <pathelement location="${classes.dest}" />
- <path refid="libraries"/>
- </classpath>
- </javac>
- <java classname="junitx.tool.TestClassValidator" fork="yes">
- <arg line="junitx.example.ValidationExample" />
- <classpath>
- <pathelement location="${classes.dest}" />
- <pathelement location="${test.classes.dest}" />
- <path refid="libraries"/>
- </classpath>
- </java>
- </target>
-
- <!--
- - Generates the junit-addons API
- -->
- <target name="api"
- depends="build"
- description="generates the API">
- <javadoc
- packagenames="junitx.*"
- sourcepath="${main.src}"
- destdir="${api.dest}"
- overview="${main.src}/overview.html"
- author="true"
- version="true"
- protected="true"
- use="false"
- windowtitle="${project.title} v${project.version}"
- doctitle="${project.title}, version ${project.version}&lt;br>API specification"
- header="&lt;b>${project.title}&lt;br>version ${project.version}&lt;/b>"
- bottom="Copyright &amp;#169; ${project.year} ${project.holder}. All Rights Reserved.">
- <classpath>
- <path refid="libraries"/>
- </classpath>
- </javadoc>
- </target>
-
- <!--
- - Generates a jar archive with the content of the build directory
- -->
- <target name="release"
- depends="clean, build"
- description="Generate the junit-addons jar archive" >
- <delete quiet="true">
- <fileset dir="${dist.dest}/" includes="${project.name}-${project.version}.jar" />
- </delete>
- <jar jarfile="${dist.dest}/${project.name}-${project.version}.jar"
- basedir="${classes.dest}" >
- <manifest>
- <attribute name="Implementation-Vendor"
- value="${project.holder}" />
- <attribute name="Implementation-Version"
- value="${project.version}" />
- <attribute name="Implementation-Title"
- value="${project.title}" />
- </manifest>
- </jar>
- <zip zipfile="${dist.dest}/${project.name}-${project.version}.jar"
- update="yes">
- <zipfileset dir="." includes="LICENSE" prefix="META-INF" />
- </zip>
- <zip zipfile="${dist.dest}/src.jar">
- <zipfileset dir="${src}" excludes="**/sflogo.png" prefix="src" />
- </zip>
- </target>
-
- <!--
- - Delete all generate directories and their content
- -->
- <target name="clean">
- <delete dir="${build.dest}" quiet="true" />
- <delete dir="${dist.dest}" quiet="true" />
- </target>
-
-</project>
diff --git a/dev-java/junit-addons/files/1.4-common.properties b/dev-java/junit-addons/files/1.4-common.properties
deleted file mode 100644
index f1e3efd9fa4a..000000000000
--- a/dev-java/junit-addons/files/1.4-common.properties
+++ /dev/null
@@ -1,15 +0,0 @@
-# ----------------------------------------------------------------------------
-# Common properties used by both the build.xml and committer.xml files.
-#
-# Taken from upstream CVS:
-# Version: Revision: 1.2 Date: 2003/04/02 04:50:33
-# Author: Vladimir R. Bossicard (vbossica@users.sourceforge.net)
-# ----------------------------------------------------------------------------
-
-# Project settings
-
-project.name = junit-addons
-project.title = JUnit-addons
-project.holder = Vladimir R. Bossicard
-project.year = 2002-2003
-project.version = 1.4
diff --git a/dev-java/junit-addons/junit-addons-1.4-r1.ebuild b/dev-java/junit-addons/junit-addons-1.4-r1.ebuild
deleted file mode 100644
index 3e5a375987af..000000000000
--- a/dev-java/junit-addons/junit-addons-1.4-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="JUnit-addons is a collection of helper classes for JUnit"
-HOMEPAGE="http://junit-addons.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
-
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-linux ~x86-macos"
-
-COMMON_DEP="
- dev-java/junit:0
- dev-java/ant-core:0
- dev-java/jdom:0
- dev-java/jaxen:1.1
- "
-
-RDEPEND=">=virtual/jre-1.4
- ${COMMON_DEP}"
-DEPEND=">=virtual/jdk-1.4
- app-arch/unzip
- ${COMMON_DEP}"
-
-java_prepare() {
- unpack ./src.jar
- rm -v *.jar || die
- # Not included so taken from cvs
- cp "${FILESDIR}/${PV}-build.xml" build.xml || die
- cp "${FILESDIR}/${PV}-common.properties" common.properties || die
-}
-
-_eant() {
- eant \
- -Djunit.jar="$(java-pkg_getjar junit junit.jar)" \
- -Dant.jar="$(java-pkg_getjar ant-core ant.jar)" \
- -Djdom.jar="$(java-pkg_getjar jdom jdom.jar)" \
- -Djaxen.jar="$(java-pkg_getjar jaxen-1.1 jaxen.jar)" \
- "${@}"
-}
-
-src_compile() {
- # javadocs are bundled
- _eant release
-}
-
-# Needs junit-addons-runner that again needs this package to build
-#src_test() {
-# cd src/test/
-# _eant -f AntTest.xml
-#}
-
-src_install() {
- java-pkg_newjar dist/${P}.jar
- dodoc README WHATSNEW || die
- use doc && java-pkg_dojavadoc api
- if use source; then
- insinto "${JAVA_PKG_SOURCESPATH}"
- newins dist/src.jar ${PN}-src.zip
- fi
-}
diff --git a/dev-java/junit-addons/metadata.xml b/dev-java/junit-addons/metadata.xml
deleted file mode 100644
index 3a46e0a4fd94..000000000000
--- a/dev-java/junit-addons/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
- <longdescription lang="en">
- JUnit-addons is a collection of helper classes for JUnit.
- This library can be used with both JUnit 3.7 and JUnit 3.8.x
- </longdescription>
- <upstream>
- <remote-id type="sourceforge">junit-addons</remote-id>
- </upstream>
-</pkgmetadata>