summaryrefslogtreecommitdiff
path: root/dev-java/jsoup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-java/jsoup
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/jsoup')
-rw-r--r--dev-java/jsoup/Manifest3
-rw-r--r--dev-java/jsoup/jsoup-1.8.3.ebuild48
-rw-r--r--dev-java/jsoup/metadata.xml20
3 files changed, 0 insertions, 71 deletions
diff --git a/dev-java/jsoup/Manifest b/dev-java/jsoup/Manifest
deleted file mode 100644
index 64a6a9f6986c..000000000000
--- a/dev-java/jsoup/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST jsoup-1.8.3a.zip 370626 BLAKE2B 9ba471a8e161ef4ad5f0abd54feb29075400a53622dcd1a9934307a123bfad087bea9fc17f3cf020929aadbf51a47b0df1aa1ad5201487394faaaf4c44a793a9 SHA512 d044231fc70ff6d5428707d56853db77feedbb29a4ea1a501e6fcbaaecb2743bdeeaa8dcf4c76f7d278905b31e83707ad2644e7876a44c9d2325537d647aab85
-EBUILD jsoup-1.8.3.ebuild 1186 BLAKE2B 449200eb4701d4a2214eeadfbbdf9f77393ef203bbb3bb3a42392cae184655e49d219728e146941fbf14d480b73d6c1ee4d7cf1d9e60c34187be74c2a6ff7ab1 SHA512 31ba7a27aaee5707d38d2a8b47f91d082cadcba8137e5163036858be8508b7af6a7a9df4e1e0dd17740ecb8e85529c5473b8a64222f04f22975185276e54a234
-MISC metadata.xml 832 BLAKE2B 29ce6790f54497fbd017bbc4e06bc623a4a79fe08989eebe33d4c5ab63e277c0f421bf5103d9c9a84fca8f0099842fb48bb047628d00374ced085f0c12535f67 SHA512 795f0cfdf9dddeb803b917a4383e5b5d6626f3ba7e9ba1c9a3225c253860e8f66934863cb6d718a6eb96ce8e49b552beb849bb9dd33880166e37c93ba3a0e0c8
diff --git a/dev-java/jsoup/jsoup-1.8.3.ebuild b/dev-java/jsoup/jsoup-1.8.3.ebuild
deleted file mode 100644
index 103a8ed904c7..000000000000
--- a/dev-java/jsoup/jsoup-1.8.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-pkg-simple
-
-MY_PV="${PV}a"
-MY_P="${PN}-${PN}-${MY_PV}"
-
-DESCRIPTION="Java HTML parser that makes sense of real-world HTML soup"
-HOMEPAGE="https://jsoup.org/"
-SRC_URI="https://github.com/jhy/${PN}/archive/${PN}-${MY_PV}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux"
-
-IUSE=""
-
-RDEPEND=">=virtual/jre-1.6"
-DEPEND=">=virtual/jdk-1.6
- test? ( dev-java/junit:4 )"
-
-S="${WORKDIR}/${MY_P}"
-
-JAVA_SRC_DIR="src/main/java"
-
-java_prepare() {
- rm pom.xml || die
- mkdir -p target/classes/org/jsoup/nodes/ || die
- cp src/main/java/org/jsoup/nodes/*.properties target/classes/org/jsoup/nodes/ || die
-}
-
-src_test() {
- testcp="${S}/${PN}.jar:$(java-pkg_getjars junit-4):target/tests"
-
- mkdir target/tests || die
- ejavac -cp "${testcp}" -d target/tests $(find src/test/java -name "*.java")
- cp -r src/test/resources/* target/tests || die
-
- tests=$(find target/tests -name "*Test.class" \
- | sed -e 's/target\/tests\///g' -e "s/\.class//" -e "s/\//./g" \
- | grep -vP '\$');
- ejunit4 -cp "${testcp}" ${tests}
-}
diff --git a/dev-java/jsoup/metadata.xml b/dev-java/jsoup/metadata.xml
deleted file mode 100644
index 423272137d7f..000000000000
--- a/dev-java/jsoup/metadata.xml
+++ /dev/null
@@ -1,20 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
- <upstream>
- <remote-id type="github">jhy/jsoup</remote-id>
- </upstream>
- <longdescription>
- jsoup is a Java library for working with real-world HTML. It provides a
- very convenient API for extracting and manipulating data, using the best
- of DOM, CSS, and jquery-like methods.
- It implements the WHATWG HTML5 specification (http://whatwg.org/html),
- and parses HTML to the same DOM as modern browsers do. It's designed to
- deal with all varieties of HTML found in the wild; from pristine and
- validating, to invalid tag-soup; jsoup will create a sensible parse tree.
- </longdescription>
-</pkgmetadata>