summaryrefslogtreecommitdiff
path: root/dev-java/jformatstring/jformatstring-2.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/jformatstring/jformatstring-2.0.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/jformatstring/jformatstring-2.0.3.ebuild')
-rw-r--r--dev-java/jformatstring/jformatstring-2.0.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-java/jformatstring/jformatstring-2.0.3.ebuild b/dev-java/jformatstring/jformatstring-2.0.3.ebuild
new file mode 100644
index 000000000000..2aaf83dfdd53
--- /dev/null
+++ b/dev-java/jformatstring/jformatstring-2.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+FINDBUGS_PV="3.0.1"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Compile time checking for Java format strings"
+SRC_URI="mirror://sourceforge/findbugs/findbugs-${FINDBUGS_PV}-source.zip"
+HOMEPAGE="https://code.google.com/p/j-format-string"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+
+src_unpack() {
+ unzip -qoj "${DISTDIR}/findbugs-${FINDBUGS_PV}-source.zip" "findbugs-${FINDBUGS_PV}/lib/jFormatString.jar" || die
+ unpack ./jFormatString.jar
+}
+
+java_prepare() {
+ find -name "*.class" -delete || die
+}