summaryrefslogtreecommitdiff
path: root/dev-java/jetty-alpn-api
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/jetty-alpn-api
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/jetty-alpn-api')
-rw-r--r--dev-java/jetty-alpn-api/Manifest4
-rw-r--r--dev-java/jetty-alpn-api/jetty-alpn-api-1.1.2.ebuild26
-rw-r--r--dev-java/jetty-alpn-api/metadata.xml14
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-java/jetty-alpn-api/Manifest b/dev-java/jetty-alpn-api/Manifest
new file mode 100644
index 000000000000..866c8aa37b7c
--- /dev/null
+++ b/dev-java/jetty-alpn-api/Manifest
@@ -0,0 +1,4 @@
+DIST alpn-api-1.1.2.v20150522.tar.gz 4246 SHA256 d6cb4ca709fee42a0f551447fbefcf66a483c78487923e671c6c553b57f3bb96 SHA512 5c7cedf80bf7b3e27fe365df2fb1a2b0f4eb5d94416f54565c960036c73a79aaee50fb7d00a0a856f2808be7dafa921b8ad89772101ff7bd97fe452a0e395e79 WHIRLPOOL b05a44bf094bd3f87699c8577ddf14e1942145464fce4caaf19a6bb7766d35851605303b25eb3caad98c0f1767fb142166e019fbe2990524c67b577b34a1b85a
+EBUILD jetty-alpn-api-1.1.2.ebuild 608 SHA256 57be25d571cb4afe4b9b5e072a6b77349858ae5b9f266524a9c8115f4aaba9da SHA512 1a15814152bf068dd1773d8e4493167ffe9da0824efd57eaa2955ea383d4276f1938a7e915ce1a14365c8003958382c6e74837e640032d9ca3f8dc7f481270fd WHIRLPOOL 581c647d277fd2b7595cc3b1888853b2abd1d98cf297c04bcb5b2c682bb80a7e3388b6379c5232031eb7efd572b0c1abbb9587038ac3bbdb3d096cd35697762d
+MISC ChangeLog 398 SHA256 aee8b6c99cf4d96a9172a40cda8d87445a91801613745f6356ada0d56ad7d7ca SHA512 1912bd64d34e2a5f0b42aac0a5121c7dabd26ad3741e7316fa467738af2c0ad101e66e353326124cbe74f137ff0a072730fb9d29d5d2557a7e42460656b195fc WHIRLPOOL 29919e246c32194a140f00b7622703a8d5adbe014565e9aca3be99af4173a7268c60bd8cb1e8ed11aaa19f29bdeaae0d0753970052627f858aeb90f3046dbe26
+MISC metadata.xml 1025 SHA256 f20f241b28f52d7857f8e256260d33b37f0dcd927015e8957aa1708ffc25851c SHA512 1bb04f6c262f4b95c6d8e0d48e46712cc7f11014db5991fc865926a5f03fa487567c08f38bbb39db66a519aad4ecd48a3128264894bbac04a4d48c06a59fe8a4 WHIRLPOOL 7c5b0618d934fb809ed965377cbee73a802233dbba9190e1c4f2f94b776c1b76c70cfbbbcefaf0d68d16c6db64748d5788f960e4216aa03025741ab86ed8044a
diff --git a/dev-java/jetty-alpn-api/jetty-alpn-api-1.1.2.ebuild b/dev-java/jetty-alpn-api/jetty-alpn-api-1.1.2.ebuild
new file mode 100644
index 000000000000..0bcb4940d608
--- /dev/null
+++ b/dev-java/jetty-alpn-api/jetty-alpn-api-1.1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_PN="${PN/jetty-/}"
+MY_PV="${PV}.v20150522"
+MY_P="${MY_PN}-${MY_PV}"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Jetty's ALPN API"
+HOMEPAGE="http://www.eclipse.org/jetty/documentation/current/alpn-chapter.html"
+SRC_URI="https://github.com/eclipse/jetty.alpn/archive/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.7"
+
+DEPEND=">=virtual/jdk-1.7"
+
+S="${WORKDIR}/${PN//-/.}-${MY_P}"
+JAVA_SRC_DIR="src/main/java"
diff --git a/dev-java/jetty-alpn-api/metadata.xml b/dev-java/jetty-alpn-api/metadata.xml
new file mode 100644
index 000000000000..d0ea9f190876
--- /dev/null
+++ b/dev-java/jetty-alpn-api/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">eclipse/jetty.alpn.api</remote-id>
+ </upstream>
+ <longdescription>The Jetty project provides an implementation of the TLS extension for ALPN for OpenJDK 7 and OpenJDK 8. ALPN allows the application layer to negotiate which protocol to use over the secure connection.
+
+Any protocol can be negotiated by ALPN within a TLS connection. The protocols that are most commonly negotiated are HTTP/2 (for browsers that support it) and, historically, SPDY. The ALPN implementation is therefore not HTTP/2 or SPDY specific in any way. Jetty's ALPN implementation, although hosted under the umbrella of the Jetty project, is independent of Jetty (the Servlet Container); you can use the ALPN implementation in any other Java network server.</longdescription>
+</pkgmetadata>