summaryrefslogtreecommitdiff
path: root/dev-java/jetty-alpn-api
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/jetty-alpn-api
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/jetty-alpn-api')
-rw-r--r--dev-java/jetty-alpn-api/Manifest3
-rw-r--r--dev-java/jetty-alpn-api/jetty-alpn-api-1.1.2.ebuild26
-rw-r--r--dev-java/jetty-alpn-api/metadata.xml16
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/jetty-alpn-api/Manifest b/dev-java/jetty-alpn-api/Manifest
new file mode 100644
index 000000000000..4e76cae9ef1c
--- /dev/null
+++ b/dev-java/jetty-alpn-api/Manifest
@@ -0,0 +1,3 @@
+DIST alpn-api-1.1.2.v20150522.tar.gz 4246 BLAKE2B 20c23033f2afb14b24ec28dc05c308f4363d0a398a25aa88e28b90e92a49c36e78450b71279e96da5d5d8047facf12f3f699743a623b6d293e8d74f3ccd1707a SHA512 5c7cedf80bf7b3e27fe365df2fb1a2b0f4eb5d94416f54565c960036c73a79aaee50fb7d00a0a856f2808be7dafa921b8ad89772101ff7bd97fe452a0e395e79
+EBUILD jetty-alpn-api-1.1.2.ebuild 608 BLAKE2B 53924240ae6fa8769767f968dee9e42739499d65c1b4e564e652e19501d0ca5ec00ccef1e4eddf3fd313266b2ac86bb8f555a97f5a1912d7fc23a55234a8fe02 SHA512 1a15814152bf068dd1773d8e4493167ffe9da0824efd57eaa2955ea383d4276f1938a7e915ce1a14365c8003958382c6e74837e640032d9ca3f8dc7f481270fd
+MISC metadata.xml 1029 BLAKE2B 266579d645a1af7055babed34e0413f5e03af1031659315e0520df3908505915139215eef7473a6ba6162f259c71b07ba8f11b132719ff5773d9cea7ef0ea399 SHA512 4debed277a9f8f6666d0595342533f6727ca7a2a5bc03f3b2828bc2523cba306b6c280bcaa275ac33726322df2de09871c5ff5a71aa3157a138372d44514293c
diff --git a/dev-java/jetty-alpn-api/jetty-alpn-api-1.1.2.ebuild b/dev-java/jetty-alpn-api/jetty-alpn-api-1.1.2.ebuild
new file mode 100644
index 000000000000..0bcb4940d608
--- /dev/null
+++ b/dev-java/jetty-alpn-api/jetty-alpn-api-1.1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_PN="${PN/jetty-/}"
+MY_PV="${PV}.v20150522"
+MY_P="${MY_PN}-${MY_PV}"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Jetty's ALPN API"
+HOMEPAGE="http://www.eclipse.org/jetty/documentation/current/alpn-chapter.html"
+SRC_URI="https://github.com/eclipse/jetty.alpn/archive/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.7"
+
+DEPEND=">=virtual/jdk-1.7"
+
+S="${WORKDIR}/${PN//-/.}-${MY_P}"
+JAVA_SRC_DIR="src/main/java"
diff --git a/dev-java/jetty-alpn-api/metadata.xml b/dev-java/jetty-alpn-api/metadata.xml
new file mode 100644
index 000000000000..e7ff4b83b664
--- /dev/null
+++ b/dev-java/jetty-alpn-api/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">eclipse/jetty.alpn.api</remote-id>
+ </upstream>
+ <longdescription>
+ The Jetty project provides an implementation of the TLS extension for ALPN for OpenJDK 7 and OpenJDK 8. ALPN allows the application layer to negotiate which protocol to use over the secure connection.
+
+ Any protocol can be negotiated by ALPN within a TLS connection. The protocols that are most commonly negotiated are HTTP/2 (for browsers that support it) and, historically, SPDY. The ALPN implementation is therefore not HTTP/2 or SPDY specific in any way. Jetty's ALPN implementation, although hosted under the umbrella of the Jetty project, is independent of Jetty (the Servlet Container); you can use the ALPN implementation in any other Java network server.
+ </longdescription>
+</pkgmetadata>